Ask Your Question
0

Turtlebot3 bring up from PC doesn't work

asked 2017-07-26 21:00:37 -0600

rozoalex gravatar image

Hi, I am very new to this. I followed exactly(I believe) this http://turtlebot3.readthedocs.io/en/l... . I run roscore on my pc and launch on my turtlebot. When I tried to bring up rviz, by type in

export TURTLEBOT3_MODEL=burger
roslaunch turtlebot3_bringup turtlebot3_model.launch

I got this,

[turtlebot3_model.launch] is neither a launch file in package [turtlebot3_bringup] nor is [turtlebot3_bringup] a launch file name
The traceback for the exception was written to the log file

I checked all the package I had on pc, and there is indeed no turtlebot3_bringup. I am confused. I just expected it to work because I followed the tutorial closely.

How do I fix it? Maybe there is some small step I missed?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-07-27 00:43:48 -0600

xnick77x gravatar image

You need to clone the turtlebot 3 github repository on your remote PC in addition to the tb3 shown in section 5.2.1.

The only thing you ever run on the tb3 is the bringup. Everything else, including RVIZ, SLAM, navigation, etc. is all done from the remote PC, hence you need to clone the repository to your remote PC.

Hope this helps!

edit flag offensive delete link more

Comments

1

Thanks! Problem solved, I sourced the wrong setup file.

rozoalex gravatar imagerozoalex ( 2017-07-27 11:05:23 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-26 21:00:37 -0600

Seen: 1,004 times

Last updated: Jul 27 '17