Turtlebot won't show up in "roslaunch turtlebot_gazebo turtlebot_world.launch"

asked 2019-07-19 05:16:39 -0500

RoboNerd gravatar image

updated 2019-07-19 05:29:35 -0500

I think ran a wrong code line in terminal but i don't remember which one was it but after that while launching

roslaunch turtlebot_gazebo turtlebot_world.launch

every model will span except the turtlebot itself and also there is another launch file that I created while learning ros in which i created a factory environment for learning URDF and xacros, imported the turtlebot for learning SLAM, it worked fine but after that wrong code line in terminal, every time i launch that file it opened up blank.

I have this error while launching roslaunch turtlebot_gazebo turtlebot_world.launch

Traceback (most recent call last):
File "/opt/ros/kinetic/lib/gazebo_ros/spawn_model", line 26, in <module> from gazebo_ros import gazebo_interface
File "/opt/ros/kinetic/lib/python2.7/dist-packages/gazebo_ros/gazebo_interface.py", line 9, in <module> from gazebo_msgs.msg import *
ImportError: No module named msg
[spawn_turtlebot_model-4] process has died [pid 6389, exit code 1, cmd /opt/ros/kinetic/lib/gazebo_ros/spawn_model -unpause -urdf -param robot_description -model mobile_base __name:=spawn_turtlebot_model __log:=/home/robonerd/.ros/log/d7c7b6ce-aa09-11e9-adfd-645a049df782/spawn_turtlebot_model-4.log]. log file: /home/robonerd/.ros/log/d7c7b6ce-aa09-11e9-adfd-645a049df782/spawn_turtlebot_model-4*.log

I do have the gazebo_msgs folder in /opt/ros/kinetic/share directory but i still receive the error. I tried reinstalling gazebo7 but the problem persists

However i was able to bring the turtlebot while launching roslaunch turtlebot_gazebo turtlebot_world.launch by sourcing

source /opt/ros/kinetic/setup.bash

Normally when it is sourced in

source ~/catkin_ws/devel/setup.bash

The trace back error appears. I recently started learning ROS so i don't have a lot of experience so please help me to solve this issue.

Thank you in Advance.

edit retag flag offensive close merge delete