Can't obtain /ardrone/navdata/pressure for tum_simulator

asked 2018-01-06 07:45:12 -0500

Ishi gravatar image

I just starting working with the tum_simulator, ardrone_autonomy and tum_ardrone packages. I am using the simulation in tum_simulator and not an actual drone. I first ran the launch file

roslaunch cvg_sim_gazebo ardrone_testworld.launch

followed by

rosrun tum_ardrone drone_gui

I am able to run the simulation and move the AR Drone using the keyboard.

However, when I run

rostopic echo /ardrone/navdata

magx, magy, magz, pressure, temp, wind_speed, wind_angle, wind_comp_angle, motor1, motor2, motor3, motor4, tags_count are all equal to 0 and not changing.

I mostly want to obtain the pressure value.

I tried adding

<param name="enable_navdata_pressure_raw" value="true" />

to the .launch file but still could not obtain the pressure value.

I also ran

rosrun ardrone_autonomy ardrone_driver enable_navdata_pressure_raw:= True

then it got stuck in Getting AR.Drone version ...


edit retag flag offensive close merge delete