Publishing cmd_vel Internally on the TurtleBot3

asked 2017-11-12 14:27:05 -0500

jonasro gravatar image

On my TurtleBot3's raspberry pi, I hooked it up to a monitor using an HDMI and created a node that publishes a Twist() to /cmd_vel. However, when I publish something such as twist.angular.z = 0.5, this is what rostopic tells me:

leonardo@leonardo:~$ rostopic info /cmd_vel Type: geometry_msgs/Twist

Publishers: * /talker ( http://hidden-ip-number/ )

Subscribers: None

Hypothetically publishing a twist should just make the turtlebot3 move, so I'm unsure what the cause might be. I tried changing the IP of the ROS_MASTER_URI and ROS_HOSTNAME from local to wlan0, but that still gives me the same result above.

Any ideas?

edit retag flag offensive close merge delete

Comments

How do you publish the message?

Humpelstilzchen gravatar imageHumpelstilzchen ( 2017-11-13 02:57:32 -0500 )edit

I got it! it wasn't an IP issue or a publishing issue, but we needed to do:

roslaunch turtlebot3_bringup turtlebot3_robot.launch
jonasro gravatar imagejonasro ( 2017-11-15 22:00:48 -0500 )edit