Why cant I run roscore on raspberry pi3?

asked 2017-10-31 20:48:15 -0500

Gideon Manik gravatar image

updated 2017-10-31 21:19:51 -0500

ahendrix gravatar image

I installed ros indigo with following this website and after sourcing and running roscore it shows:

Traceback (most recent call last):
  File "/opt/ros/indigo/bin/roscore", line 69, in <module>
    import roslaunch
  File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/__init__.py", line 61, in <module>
    from .scriptapi import ROSLaunch
  File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/scriptapi.py", line 42, in <module>
    import roslaunch.parent
  File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/parent.py", line 54, in <module>
    import roslaunch.server
  File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/server.py", line 78, in <module>
    from rosgraph_msgs.msg import Log
ImportError: No module named rosgraph_msgs.msg

P.S i tried reinstalling again but results were the same. Using debian jessie

edit retag flag offensive close merge delete

Comments

1

It looks like your PYTHONPATH isn't set correctly. Did you source the setup.bash or setup.sh for your ROS installation before trying to start roscore?

ahendrix gravatar image ahendrix  ( 2017-10-31 21:20:31 -0500 )edit
1

It would also help to know which OS you're using, whether it's a 32-bit OS or 64-bit, and which instructions you followed to install ROS.

ahendrix gravatar image ahendrix  ( 2017-10-31 21:21:23 -0500 )edit