Ask Your Question
0

Kinect working, but not connection to freenect or openni

asked 2017-08-21 06:41:25 -0500

budekatude gravatar image

updated 2017-08-21 19:07:08 -0500

jayess gravatar image

Hi all,

this seems to be a widespread problem, but even with all the proposed solutions I don't seem to get it to work:

I am trying to use a Microsoft Kinect v2 with ROS.

The camera is connected and I can stream the images using

rosrun kinect2_viewer kinect2_viewer

Therefore I concluded that the basic connection to the camera is working fine. Unfortunately when I try to connect to the camera using freenect

roslaunch freenect_launch freenect.launch

I don't seem to be able to get it to work, producing the following error message:

[ INFO] [1503322404.266304684]: No devices connected.... waiting for devices to be connected

I have also tried using openNI, which produces the same error message in the process.

I know this is a well discussed error in the community and I've tried various suggested solutions from reinstalling freenect and openNI respectively, applying a patch (as seen in: https://answers.ros.org/question/6056... ) and everything else that was suggested...

But so far nothing seemed to work! Still getting the same error about not finding the Kinect...

Any sort of pointer or hint in a direction is extremely appreciated! I'm running out of ideas (even for new ways to google the issue!)

Thanks in advance everyone!

P.S.: I am using ROS Indigo and Ubuntu 14.04 with a Kinect v2 connected to a USB 3.0 port

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-09-08 03:05:10 -0500

budekatude gravatar image

After trying lots of different drivers and setups I managed to get it to work after reinstalling everything and using Kinect2_bridge instead of openni or freenect (apparently they don't support the Kinect v2).

Simply following the installation instructions on GitHub will leave you with a working solution. ( https://github.com/code-iai/iai_kinect2 )

Thanks Solrac3589 for your suggestion!

edit flag offensive delete link more
0

answered 2017-08-24 04:37:17 -0500

Solrac3589 gravatar image

I'm not completely sure, but i think with kinect v2 you have to use freenect2, isnt?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-08-21 06:41:25 -0500

Seen: 325 times

Last updated: Sep 08 '17