Ask Your Question
0

ROS Indigo and libav libraries' version

asked 2014-07-31 21:40:26 -0600

Mehdi. gravatar image

updated 2014-07-31 23:21:34 -0600

I updated my computer from Ubuntu 12.04 ROS Hydro to ubuntu 14.04 ROS Indigo. One node is causing me problems. It is a C++ node, a kind of modification of the face_recognition package

Now when I try to start it, my system complains that libavformat.so.53 was not found (It was complaining about libtiff4 so I somehow managed to install it manually from the binaries for ubuntu 13). I searched for it and I found it in Trash while in the /usr/lib/x86_64-linux-gnu/ folder there was a newer version libavformat.so.54. I actually don't have any idea where this dependency comes from, I never added it, maybe from OpenCV?

I tried copying it manually (impossible to install libavformat 53 on 14.04) to the libs folder and my node finally worked. The problem now is that when I start the face recognition, there is no window appearing with the webcam images published to the topic I subscribe to. I just get the "Opengl support available" that one normally gets before a window is opened with OpenCv. I am suspecting this manual copy of the library to cause this weird behavior. My node worked fine on Ubuntu 12.04

I also had this same experience in the past with other packages but under 12.04 with Hydro and Groovy, Face Tracking and Camera calibration did both start but just show "Opengl support available" and stop there, no window with webcam images is shown.

I also tried to run some other packages that use images, image_view for example returns the same error (libavformat.so.53 not found) can somebody reproduce this error?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-08-01 04:00:06 -0600

Mehdi. gravatar image

Ok I could solve this problem finally. libopencv-dev was causing all the troubles. Somehow libopencv-dev was installed by apt-get without caring about some missing dependencies. I deleted it, and tried to compile OpenCv by myself but got some errors about some static libraries (.a) that cannot be linked and asked me to recompile with -fPIC. So I followed this tutorial to compile OpenCV

http://www.ozbotz.org/opencv-installa...

It worked and I have the latest stable OpenCV version now. My face recognition is also working again like it did before on Hydro with Ubuntu 12.04.

edit flag offensive delete link more
0

answered 2014-08-01 02:51:21 -0600

ahendrix gravatar image

If you've upgraded your machine to a new version of Ubuntu and upgraded to a new version of ROS, you should probably delete the build and devel folders in your workspace and rebuild them from scratch.

edit flag offensive delete link more

Comments

Sorry I forgot to mention that, I just copied the source code and recompiled, I still don't understand how it compiles with no errors even with missing libraries...

Mehdi. gravatar imageMehdi. ( 2014-08-01 03:00:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-31 21:40:26 -0600

Seen: 244 times

Last updated: Aug 01 '14