Ask Your Question
0

Freenect_launch does not detect Kinect, BeagleBoard-xM, Ubuntu [closed]

asked 2014-01-14 04:10:02 -0500

Gour gravatar image

updated 2016-10-24 08:35:39 -0500

ngrennan gravatar image

Hi,

I'm trying to run the freenect_launch package on a BeagleBoard-xM (Rev C) running Ubuntu 13.04. The aim is to record a short rosbag of kinect data and store it, to be later transmitted for offboard processing.

The prebuilt demo image of Ubuntu was installed following the instructions on the elinux page for BeagleBoardUbuntu.

I installed ros-hydro-freenect-launch using apt-get.

roslaunch freenect_launch freenect.launch successfully launches roscore and starts the kinect-related processes, but does not detect the kinect. It repeatedly displays

No devices connected.... waiting for devices to be connected

I've tried blacklisting the gspca_kinect module, but to no avail.

lsusb shows that the Kinect is recognized:

Bus 001 Device 012: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 001 Device 011: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 001 Device 013: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

I'd really appreciate if someone could help getting freenect to recognize the kinect, or suggest alternatives.

EDIT 1:

We are no longer facing this issue with the latest release of Ros-hydro for Ubuntu-ARM (the hydro/Installation/UbuntuARM page has been updated on 18th Jan 2014) with the namniart repositories. We have also switched over to a Pandaboard (Rev A3) for greater computing power, so we cannot say for sure that the issue has been resolved on the Beagleboard-xM.

After installing ros-hydro-freenect-stack on Ubuntu 13.04 (OMAP4 Desktop Image) on the Pandaboard, freenect.launch detects the Kinect and publishes topics successfully.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-08-14 01:55:21.754365

Comments

1

The last time I tried this, it didn't work.

ahendrix gravatar imageahendrix ( 2014-01-20 11:21:24 -0500 )edit

Thank you for the response. Freenect-launch worked with the Kinect on a Pandaboard after the recent repository update.

Gour gravatar imageGour ( 2014-01-21 01:48:58 -0500 )edit

Awesome! Can you post that as an answer? (Yes, you're allowed to answer your own question)

ahendrix gravatar imageahendrix ( 2014-01-21 07:47:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
-1

answered 2014-01-21 16:59:19 -0500

DrBot gravatar image

On Pandaboard Ubuntu 13.04, hydro freenect launch says:

process[camera/disparity_registered_sw-17]: started with pid [3840] process[camera/disparity_registered_hw-18]: started with pid [3884] process[camera_base_link-19]: started with pid [3902] process[camera_base_link1-20]: started with pid [3927] process[camera_base_link2-21]: started with pid [3948] process[camera_base_link3-22]: started with pid [3963] rostopic list shows lots of topics, but echo shows they are all empty of data.

This is the same for openni launch.

I am guessing something to do with USB 3 vs 2? -or- bad calibration file?

edit flag offensive delete link more

Comments

This is not an answer. Please ask it as a new question.

ahendrix gravatar imageahendrix ( 2014-01-21 20:44:27 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2014-01-14 04:10:02 -0500

Seen: 455 times

Last updated: Jan 21 '14