Ask Your Question
0

Kinect for Windows Install Ubuntu 13.04 w/Hydro

asked 2014-02-20 20:52:54 -0600

Victor Gomez gravatar image

updated 2016-10-24 08:36:20 -0600

ngrennan gravatar image

Good day everyone,

I've been trying different settings to achieve this, with no success. My settings are as follow:
Ubuntu 13.04
ROS version Hydro Medusa
freenect_stack install as in (can't insert link) the install instructions of the wiki
Kinect for Windows 1517 fully functional (tested with Microsoft SDK)

I've tried in two different computers, same settings, the difference between them is:

  1. XPS Dell - 2 USB port 3.0 + 1 USB/eSATA combo port.
  2. Assembly computer with 6 USB port 3.0

So far, what I've read is that, as I'm using Ubuntu 13.04 I don't need to do the kernel update to fix USB 3.0 (can't insert link yet) . Nevertheless the result is exactly the same wheter I use the 3.0 ports or the combo one. After using the command roslaunch freenect_launch freenect.launch I get the following error:

[ INFO] [1393001100.077038281]: No devices connected.... waiting for devices to be connected
[ INFO] [1393001103.079356057]: No devices connected.... waiting for devices to be connected

Using the command usbls I get the following:

Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 003 Device 008: ID 045e:02c2 Microsoft Corp.
Bus 003 Device 002: ID 05af:1023 Jing-Mold Enterprise Co., Ltd
Bus 003 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 004: ID 22b8:710f Motorola PCS
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 011: ID 045e:02be Microsoft Corp.
Bus 003 Device 012: ID 045e:02bf Microsoft Corp.

My guess is that the Microsoft Corp devices are the Kinect Audio, Camera and Aux (The ID 045e corresponds to it).

Any help, suggestion, recommendation with this? It's really driving me crazy. Let me know if I can give you any more information. Thank you!

Regards

edit retag flag offensive close merge delete

Comments

Will openni_launch, support kinect xbox (model 1414) for ubuntu 14.04 lts, ros indigo?

blackmamba591 gravatar imageblackmamba591 ( 2015-09-22 21:17:14 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-03-11 21:22:22 -0600

Victor Gomez gravatar image

Good day everyone. I've been working so far with this problem and I've got a answer. Maybe it's not the most convenient one, but I got results.

So far, everything I've been reading says only Kinect, never specifing which type of Kinect. In my lab we had the previously described one. Today, I went to a friends house and borrowed his Kinect for Xbox 360 (model 1414). I tried all the previous instructions, and checked as instructed by expelliarmus the OpenNi_launch page. Finally, Kinect is working with Linux, is being recognized and I can start testing ASAP.

Summarizing, use a Kinect for Xbox 360.

However, take into consideration that this version does not include a USB, so you need to use an adapter which supplies power to the Kinect and also enables the USB (e.g. The one supplied with Kinect for Windows, which I'm using ATM)

edit flag offensive delete link more

Comments

Will openni_launch, support kinect xbox (model 1414) for ubuntu 14.04 lts, ros indigo?

blackmamba591 gravatar imageblackmamba591 ( 2015-09-22 21:17:33 -0600 )edit
0

answered 2014-02-21 12:04:35 -0600

How about taking a look at OpenNi_launch page.

edit flag offensive delete link more

Comments

Thank you. I already check it. Whenever I try to start the **roslaunch openni_launch openni.launch ** I receive an error that reads:
[openni.launch] is neither a launch file in package [openni_launch] nor is [openni_launch] a launch file name
I also tried ** roslaunch freenect_launch freenect-xyz.launch**, but still receive the "No devices connected..." error.

Victor Gomez gravatar imageVictor Gomez ( 2014-02-21 18:31:21 -0600 )edit

You do not openni package installed. Try this command and see: sudo apt-get install ros-hydro-openni-launch

expelliarmus gravatar imageexpelliarmus ( 2014-02-24 05:54:27 -0600 )edit

Sorry for taking so long to try this. As you said, I didn't have the package installed. Nevertheless with the roslaunch openni_launch openni.launch I still get the "No devices connected..." I also tried the roslaunch freenect_launch freenect-xyz.launch with same results. I think the problem is that lsusb shows the Kinect is pluged in, but it just recognizes it as Microsoft Corp. I don't know if the version of my kinect has something to do with it (Kinect for windows 1517)

Victor Gomez gravatar imageVictor Gomez ( 2014-02-27 14:20:41 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-20 20:52:54 -0600

Seen: 923 times

Last updated: Mar 11 '14