Ask Your Question
0

Color format for monochrome YUYV camera all messed up.

asked 2017-07-16 16:22:33 -0500

psammut gravatar image

updated 2017-07-17 19:37:25 -0500

I have a see3cam_10CUG camera that I've been using with ROS.

I originally installed uvc_camera and it worked just fine. I then tried to get the libuvc_camera library to work with this camera and went through lots of pain but I couldn't get the camera to work due to errors.

I then tried going back to uvc_camera and now my image looks like this: image description

Is there any way I can change the pixel format for uvc_camera to work?

edit retag flag offensive close merge delete

Comments

That kinda looks like a raw bayer-pattern image from a color image sensor, before debayering.

ahendrix gravatar imageahendrix ( 2017-07-16 21:19:00 -0500 )edit

@psammut: could I ask you to attach your image to this post directly (instead of hosting it on imgur)? I've given you enough karma to do so.

gvdhoorn gravatar imagegvdhoorn ( 2017-07-17 06:41:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-07-17 19:48:17 -0500

psammut gravatar image

Ok so I feel a little stupid about this one.

I first tried the uvc_camera library and ran it with this launch file and it worked:

<?xml version="1.0"?>
<launch>
  <!-- Camera -->
  <node ns="/camera" pkg="uvc_camera" type="uvc_camera_node" name="camera">
    <param name="device" value="/dev/video0"/>
  </node>
</launch>

I then tried another uvc camera library that gives more access to the see3cam_10CUG's exposure parameters, which is here: https://github.com/dgossow/see3cam

Problem here is two fold. That special see3cam library is actually for the see3ceam_10CUG_C camera, which is the color version, hence why it was giving me the weird bayer encoding for the monochrome image.

I then deleted this package and tried to go back to using the uvc_camera library. To my horror I'd get the same messed up picture. The problem here is that the see3cam library uses the same package name as uvc_camera, and even though I had deleted the source and ran catkin_make, the binaries were still in the build folder and they were getting loaded when I was trying to load the regular uvc_camera driver. So, I deleted the build folder, rebuilt without the see3cam package and everything worked and went back to normal.

I wish libuvc_camera worked with this camera, so I could get on the fly exposure control, but I spent a day on trying to get it to work and couldn't so uvc_camera it is.

Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-16 16:22:33 -0500

Seen: 150 times

Last updated: Jul 17 '17