Ask Your Question
0

Error when launching uvc_camera

asked 2015-01-15 21:14:56 -0500

Anna gravatar image

updated 2015-01-15 22:09:16 -0500

ahendrix gravatar image

Hi I am currently trying to use uvc_camera with my project but when i launch it i get this error with my codes.
( This are my error)

NODES
/
camera_node (uvc_camera/camera_node)
find_object_2d (find_object_2d/find_object_2d)
objects_detected (find_object_2d/objects_detected)

ERROR: cannot launch node of type [uvc_camera/camera_node]: uvc_camera
ROS path [0]=/opt/ros/hydro/share/ros 
ROS path [1]=/home/anna/ASD/src
ROS path [2]=/opt/ros/hydro/share
ROS path [3]=/opt/ros/hydro/stacks

Would appreciate anyone that is able to help! Thanks in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-01-15 22:11:44 -0500

ahendrix gravatar image

There are two common causes for problems like this:

  1. You don't have the uvc_camera package installed. Try installing it by using sudo apt-get install ros-hydro-uvc-camera
  2. You've checked out the uvc_camera package from source, but haven't compiled it. Either compile it, or remove it from your workspace and install it through apt (see #1)
edit flag offensive delete link more

Comments

Hi sir, how do we edit the uvc_camera launch folder to launch a usb camera asus xtion pro live. Awesome help by the way thanks in advance!

Anna gravatar imageAnna ( 2015-01-18 04:18:50 -0500 )edit
1

The Asus Xtion Pro Live isn't a normal USB camera; you should use the openni or openni2 drivers for it. If you're having trouble with it, please ask a new question.

ahendrix gravatar imageahendrix ( 2015-01-18 11:03:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-15 21:14:56 -0500

Seen: 1,438 times

Last updated: Jan 15 '15