Ask Your Question
0

Unable to load calibration file in uvc_camera over network

asked 2013-02-04 00:50:06 -0500

daddy1988 gravatar image

updated 2013-02-05 04:15:18 -0500

joq gravatar image

I tried to launch a node over the network with the following code:

<node machine="$(arg machine)" name="uvc_camera_bsl12" pkg="uvc_camera" type="stereo_node">
<param name="left/device" value="$(arg ldev)" />
<param name="right/device" value="$(arg rdev)" />
<param name="left/camera_info_url" value="file://$(find baseline12)/data/camera_yaml/bsl12_left_01.yaml" />
<param name="right/camera_info_url" value="file://$(find baseline12)/data/camera_yaml/bsl12_right_01.yaml" />
<param name="fps" value="15" />
<param name="skip_frames" value="3" />
<param name="width" value="640" />
<param name="height" value="480" />
<param name="frame_id" value="baseline12" />
<param name="left/rotate" value="false" />
<param name="right/rotate" value="false" />
</node>

but it says

rectified topic '/baseline12/left/image_rect_color' requested but camera publishing '/baseline12/left/camera_info' is uncalibrated

It seems that it doesn't load .yaml file because $(find) command load local path instead remote path.

Do you have any suggestion? Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-05 04:16:40 -0500

joq gravatar image

updated 2013-02-05 04:20:52 -0500

Check out a copy of the baseline12 package on the remote machine.

It would be possible, but tricky, for camera_info_manager to support http: URLs directly. If you feel you need it, please open an enhancement ticket.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-04 00:50:06 -0500

Seen: 175 times

Last updated: Feb 05 '13