ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rqt rqt_graph rqt_plot does't work Segmentation fault (core dumped)

asked 2017-04-26 10:17:49 -0600

RaduM17 gravatar image

What I recive is: Segmentation fault (core dumped)

I tryed to remove config files from ~/.config/ I also reinstall ros-indigo-rqt Still not working.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2017-10-23 17:50:30 -0600

PushyamiK gravatar image

I had the same problem. When I checked the Ubuntu crash report I realized that the error was coming from Qt library. I had a software package which was referencing QT libs from a different path. Once I setup the environment variable LD_LIBRARY_PATH=<qt home="" directory="">/5.7/gcc_64/lib I was able to run rqt without segfault. Hope this helps.

edit flag offensive delete link more


It worked for me!

M_Sathler gravatar image M_Sathler  ( 2021-06-29 16:21:24 -0600 )edit

answered 2018-02-15 13:36:47 -0600

I have the same issue. And I tried this it works on my system (Ubuntu 16.04.3 LTS):

  1. Remove python-sip

    sudo apt remove python-sip

  2. Reinstall the ROS (This will just install the packages related to pyqt etc., which is just 41 MB). I installed kinetic so the code is

    sudo apt-get install ros-kinetic-desktop-full

  3. At the end update and upgrade the system
    sudo apt-get update
    sudo apt-get upgrade

edit flag offensive delete link more


I tried your solution on ubuntu 16 with ors kinetic, but the issue still there

Abdu gravatar image Abdu  ( 2018-06-29 16:42:44 -0600 )edit

Question Tools

1 follower


Asked: 2017-04-26 10:17:49 -0600

Seen: 2,053 times

Last updated: Apr 26 '17