Ask Your Question
0

rqt_graph GUI not working

asked 2013-05-06 07:30:38 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello,

I am following the steps described in "Understanding ROS Topics" tutorial.

When I try to launch rqt_graph in the console I get this output:

    user@user:~$ rosrun rqt_graph rqt_graph 
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored

Which I believe is a normal output.

The rqt graph window opens but nothing is shown in it.

I don't know what could be wrong.

Thank you,

edit retag flag offensive close merge delete

Comments

1

Here is a screenshot of what I'm seeing: http://screencloud.net/v/qpXV

Pino gravatar imagePino ( 2013-05-06 07:55:52 -0600 )edit
1

This screenshot helps more to understand what's happening, and that looks odd. What happens when you run $ rqt from command line and open "Plugins" --> "Graph" on it?

130s gravatar image130s ( 2013-05-06 08:00:37 -0600 )edit

This works, now I can see the graph as shown here: http://screencloud.net/v/2bR7 But trying to run it directly using $ rosrun rqt_graph rqt_graph still doesn't work

Pino gravatar imagePino ( 2013-05-06 10:18:39 -0600 )edit

@Pino so if you open rqt_graph via rqt, not directly, do you see nodes & topics or whatever you wanted to see?

130s gravatar image130s ( 2013-05-06 10:45:02 -0600 )edit

Yes, opening via rqt solves the problem

Pino gravatar imagePino ( 2013-06-10 09:48:36 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-06 07:57:52 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

AttributeError seems to be python's bug, not ROS, as you might already be aware of.

I just ran that tutorial and have no problem with it. Make sure your terminal you use points to ros master where your nodes running with. It can be verified by commands like:

$ echo $ROS_MASTER_URI 
http://localhost:11311  (you should see this if you're running master on local machine and made no change to port number)

Update 5/8/13, copying from my comment section) Work around might be to open rqt_graph from rqt's integrated GUI by:

$ rqt

and open "Plugins" --> "Graph".

In the 2nd snapshot you shared, graph is not yet shown. Do you just forget to take snapshot where graph is shown? Or does the graph not appear yet even though everything else is working correctly (if so that's still a problem. Might be worth opening a ticket on github)?

edit flag offensive delete link more

Comments

Yes, I first believed this was the source of the problem but checked and it's a common error. I did what you suggested and got your same response: $ echo $ROS_MASTER_URI http://localhost:11311

Pino gravatar imagePino ( 2013-05-06 10:13:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-05-06 07:30:38 -0600

Seen: 2,319 times

Last updated: May 07 '13