Ask Your Question
0

rqt_graph crashes

asked 2014-09-16 07:44:33 -0600

Tomaszz gravatar image

updated 2014-09-18 16:47:15 -0600

Dirk Thomas gravatar image

After running $ rosrun rqt_graph rqt_graph

i get the following error msg:

PluginHandlerDirect._restore_settings() plugin "rqt_graph/RosGraph#0" raised an exception:
Traceback (most recent call last):
  File "/opt/ros/indigo/lib/python2.7/dist-packages/qt_gui/plugin_handler_direct.py", line 116, in _restore_settings
    self._plugin.restore_settings(plugin_settings_plugin, instance_settings_plugin)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 202, in restore_settings
    self._refresh_rosgraph()
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 226, in _refresh_rosgraph
    self._update_graph_view(self._generate_dotcode())
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 259, in _update_graph_view
    self._redraw_graph_view()
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 292, in _redraw_graph_view
    same_label_siblings=True)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/qt_dotgraph/dot_to_qt.py", line 254, in dotcode_to_qt_items
    subgraph_nodeitem = self.getNodeItemForSubgraph(subgraph, highlight_level)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/qt_dotgraph/dot_to_qt.py", line 83, in getNodeItemForSubgraph
    bb = subgraph.attr['bb'].strip('"').split(',')
KeyError: 'bb'
edit retag flag offensive close merge delete

Comments

What version of these two packages do you use: rqt_graph and qt_dotgraph? Also please provide more information since you are likely doing more than what you described. E.g. which packages did you try to visualize in the graph?

Dirk Thomas gravatar imageDirk Thomas ( 2014-09-18 16:49:56 -0600 )edit

Well, I'm not sure what do you mean by version of rqt_graph. I use ROS Indigo. Problems with rqt_graph started when using VREP together with ROS. For the first time it crashed when I played the simulation on VREP. Officially VREP doesn't support ROS Indigo. Now each rqt_graph run fails.

Tomaszz gravatar imageTomaszz ( 2014-09-19 04:11:09 -0600 )edit

With "version" I mean the version of the Debian package you have installed. Please run "dpkg -l | grep rqt-graph" and "dpkg -l | grep qt-dotgraph" and post the result. My second question was: which packages did you try to visualize in the graph?

Dirk Thomas gravatar imageDirk Thomas ( 2014-09-19 10:21:37 -0600 )edit

1/ ros-indigo-rqt-graph 0.3.9-0trusty-20140905-0110-+0000 amd64 ros-indigo-qt-dotgraph 0.2.26-0trusty-20140819-0222-+0000 amd64

2/ i tried to visualize vrep tutorials packages "ros_bubble_rob", "vrep_joy" etc

actually now it works fine :P I have restarted my laptop

Tomaszz gravatar imageTomaszz ( 2014-09-20 05:04:31 -0600 )edit

I get exactly the same error message. I have ros-indigo-rqt-graph 0.3.9-0trusty-20140905-0309-+0000 i386 and ros-indigo-qt-dotgraph 0.2.26-0trusty-20140819-0326-+0000 i386, i don't use VREP. This happens even if no ros nodes are running, just a roscore.

Robopija gravatar imageRobopija ( 2014-09-26 10:23:30 -0600 )edit

I have the same problem. Restarting Ubuntu helps at first, but error came back. Installing ros-indigo-qt-gui-app and ros-indigo-qt-gui-core did not help for me so far.

ros-indigo-rqt-graph 0.3.10-0trusty-20141230-0525-+0000 amd64 ros-indigo-qt-dotgraph 0.2.26-0trusty-20141230-0049-+0000 amd64

VinceDietrich gravatar imageVinceDietrich ( 2015-02-19 07:03:44 -0600 )edit

If anybody could come up with a minimal example to reproduce the issue it might be feasible to fix the problem.

Dirk Thomas gravatar imageDirk Thomas ( 2015-02-19 12:57:03 -0600 )edit

Hello: I get the same problem. My versions are

ii ros-indigo-rqt-graph 0.3.10-0trusty-20141230-0525-+0000 amd64

ii ros-indigo-qt-dotgraph 0.2.26-0trusty-20141230-0049-+0000 amd64

and I am trying to use rqt_graph as on A Gentle Introduction to ROS (J.M. O'Kane) p24

Will Chamberlain gravatar imageWill Chamberlain ( 2015-02-25 23:38:51 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-09-30 20:20:21 -0600

DataCrusader21 gravatar image

I can vouch for Tomaszz, restarting Ubuntu after installing rqt_graph and plugins fixes this issue.

edit flag offensive delete link more
0

answered 2015-06-10 01:45:45 -0600

John Nagle gravatar image

Working through the ROS tutorials with ROS Jade. Current system: Ubuntu 14.04 LTS / 64 bit. Default installation of ROS Jade. One patch: "https://github.com/ros-visualization/python_qt_binding/issues/24" "binding_helper fails when "future" package is installed"

Same problem as above, at "http://wiki.ros.org/ROS/Tutorials/UsingRqtconsoleRoslaunch", step 1.2.5, "roslaunching". File launches OK. Both "TurtleSim" windows open.

$ rostopic pub /turtlesim1/turtle1/cmd_vel geometry_msgs/Twist -r 1 -- '[2.0, 0.0, 0.0]' '[0.0, 0.0, -1.8]'

is issued per the tutorial instructions. The turtles start moving in circles as they should.

The next step is to run "rqt_graph". That crashes:

$ rqt_graph
PluginHandlerDirect._restore_settings() plugin "rqt_graph/RosGraph#0" raised an exception:
Traceback (most recent call last):
...
File "/opt/ros/jade/lib/python2.7/dist-packages/qt_dotgraph/dot_to_qt.py", line 83, in getNodeItemForSubgraph
bb = subgraph.attr['bb'].strip('"').split(',')
KeyError: 'bb'

So there's an easy way to reproduce the problem in ROS Jade. This is a standard tutorial.

After digging through the issues and sources, a fix, or at least a patch to make it not crash, was committed one day ago:

https://github.com/ros-visualization/...

Has that been through regression testing yet? Do I have to patch the installation manually, or is there some way to update the ROS Jade more cleanly? I don't want to build from source at this time. I just use a version where I can do all the tutorials without something blowing up.

edit flag offensive delete link more

Comments

The package qt_gui_core has been fixed (0.2.28). The new debs are in the building repo ( http://www.ros.org/debbuild/jade.html... ). Once all downstream packages have finished rebuilding they will appear in ros-shadow-fixed and after a short soak time be synced to the ros repo.

Dirk Thomas gravatar imageDirk Thomas ( 2015-06-10 09:48:45 -0600 )edit

just edit by manually ,then remove the file dot_to_qt.pyc, your modified file dot_to_qt.py will be generate new dot_to_qt.pyc, it will works.

shhu1993 gravatar imageshhu1993 ( 2015-06-14 06:54:06 -0600 )edit
0

answered 2015-02-18 08:59:26 -0600

mukhachev gravatar image

Under Ubuntu 14.04 it helped for me to install ros-indigo-qt-gui-app and ros-indigo-qt-gui-core

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-09-16 07:44:33 -0600

Seen: 2,480 times

Last updated: Jun 10 '15