ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rqt_plot not publishing showing anything

asked 2013-07-25 04:06:04 -0500

Gudjohnson gravatar image

updated 2013-11-14 10:58:13 -0500

tfoote gravatar image

rqt_plot not publishing anything even thought there is data being published on the topic "mytopic". When I do rostopic echo /mytopic I get continious output with parameters changing given as follows(just posted a script out of the big output I am getting) :

  id: 3
    vs: 4

    id: 10
    vs: 1

    id: 13
    vs: 6

    id: 18
    vs: 1

    id: 19
    vs: 1

    id: 21
    vs: 8

    id: 27
    vs: 1

    id: 31
    vs: 1

However when I do rosrun rqt_plot rqt_plot /mytopic nothing is ouputted. Can somebody help me with this.

edit retag flag offensive close merge delete


What data types are the members of your topic? Are they numeric?

130s gravatar image 130s  ( 2013-08-07 14:51:02 -0500 )edit

3 Answers

Sort by » oldest newest most voted

answered 2013-07-25 04:27:30 -0500

130s gravatar image

updated 2013-07-25 04:28:09 -0500


$ rqt_plot /%TOPIC_NAME%/%FIELD_NAME%

In your case:

$ rqt_plot /mytopic/id /mytopic/vs

Hope this works.

edit flag offensive delete link more


unfortunately this does not work. I do not understand why it does not work. For rosrun rqt_graph rqt_graph I get a graph in which I have one note which is publishing and subscribing to my /mytopic. rqt_plot should output the data being published on a topic but it does not show anything althought "rostopic echo /mytopic" shows that data is being published on mytopic.

Gudjohnson gravatar image Gudjohnson  ( 2013-07-25 07:10:58 -0500 )edit

I'm not sure either. Try `rosdep install rqt_plot` (this installs missing dependency if any) and tell us the result.

130s gravatar image 130s  ( 2013-08-07 21:08:52 -0500 )edit

answered 2022-11-29 05:50:51 -0500

Domi gravatar image

I know this is an old thread but I just want to post it here in case it would help anyone...

In order for rqt_plot to plot your topic, it should include a timestamp. In other words, add a header to your customized message and write my_msg.header.stamp in it, then rqt_plot should work.

edit flag offensive delete link more

answered 2013-10-10 01:11:57 -0500

The same was happening to me. I checked the help message in rqt_plot and tried adding the flag "--args", then it worked! In your case you can try

rqt_plot --args /mytopic/id /mytopic/vs
edit flag offensive delete link more

Question Tools



Asked: 2013-07-25 04:06:04 -0500

Seen: 5,200 times

Last updated: Oct 10 '13