Ask Your Question
0

Could not initialise Stage with Segmentation fault error

asked 2011-07-18 23:27:45 -0500

Tuan gravatar image

Hi,

I am new to ROS so please help me with this.

I follow the tutorial to set up Stage and everything was fine until I am trying to use stageros to load an existing world file (also part of the tutorial)

Input:

tuan@tuan-laptop:/opt/ros/diamondback/stacks/simulator_stage/stage$ ./bin/stageros world/willow-erratic.world

Output:

Segmentation fault.

The error message is too simple and do not provide much information for me to debug. Please help.

Thanks very much.

Tuan.

edit retag flag offensive close merge delete

Comments

Can you load any other world file? Do you get any output besides "Segmentation Fault"?
Eric Perko gravatar image Eric Perko  ( 2011-07-19 00:28:46 -0500 )edit
Can you try it in a debugger (`gdb --args ./bin/stageros world/willow-erratic.world`) and post a backtrace (`bt`) from the segfault?
Brian Gerkey gravatar image Brian Gerkey  ( 2011-07-19 03:51:57 -0500 )edit
Thanks very much. I was using Ubuntu 10.04 and the problem is solved when I upgrade to Ubuntu 10.10. I really appreciate your help. Tuan.
Tuan gravatar image Tuan  ( 2011-07-31 07:55:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-11-18 05:33:39 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

As @Tuan said, upgrading to 10.10 worked, more like cannot reproduce.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-18 23:27:45 -0500

Seen: 461 times

Last updated: Nov 18 '11