Ask Your Question
0

Moveit: "Group 'arm' includes joints that have more than 1 DOF

asked 2017-02-17 16:58:54 -0500

craigc gravatar image

I have this error message from ROS when loading the model in the C++ ROS node. All joints in the model have only 1 axis of rotation so this message does not make sense. is there any reason why this message might be showing up?

edit retag flag offensive close merge delete

Comments

Could you post your urdf?

NEngelhard gravatar image NEngelhard  ( 2017-02-18 04:46:49 -0500 )edit

The code will not post well but the URDF code is hosted at https://github.com/greenpro/sac_descr...

The rest of the description project is at https://github.com/greenpro/sac_descr...

craigc gravatar image craigc  ( 2017-02-18 20:19:13 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2017-02-19 03:58:34 -0500

gvdhoorn gravatar image

updated 2017-02-19 04:01:44 -0500

First: the error message you quote is actually not coming from MoveIt itself, but from the kinematics plugin you have configured for your arm group. MoveIt itself doesn't really care, but plugins like KDL, LMA and others don't support joints with more than a single dof.

As to a possible cause: in greenpro/sac_config/config/andreas_arm.srdf (here) you have:

<group name="arm">
    <joint name="virtual_joint" />
    ...
</group>
...
<virtual_joint name="virtual_joint" type="planar" parent_frame="odom_combined" child_link="world" />

Your arm group includes virtual_joint, which you have configured as a planar joint. Planar joints combine 2 dof, so I think that is where your error message is coming from.

Btw: the virtual joint is typically not included in any group, as it is the joint that connects your robot / cell to the 'world'.

edit flag offensive delete link more

Comments

From greenpro/sac_config@67d1af6463da688cededec1a0def76129ff7209e I have the impression that you've solved the problem by removing the virtual joint frome the arm group?

gvdhoorn gravatar image gvdhoorn  ( 2017-02-24 14:11:18 -0500 )edit

I solved the problem by remaking the project using the setup assistant and changing the joint to a fixed joint. The removal was from a previous attempt to solve the problem. The configuration is now at https://github.com/greenpro/scorbot_c...

craigc gravatar image craigc  ( 2017-02-24 15:06:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-02-17 16:58:54 -0500

Seen: 210 times

Last updated: Feb 19 '17