Visualization broken when using a ns. Can visualize in image_view, but having RViz issues

asked 2017-02-07 10:26:55 -0500

ljarin gravatar image

updated 2017-02-07 16:52:16 -0500

I'm trying to visualize camera data in Rviz (ex: turtlebot_gazebo's camera). It works fine, but when I put the node launch in a namespace, it stops working in RViz (but still works in image_view and I can see the data in rostopic echo). With the fixed frame base_footprint, I get "Camera Info OK, Image No Image Received, Topic OK" and

[ WARN] [1486484666.162398135, 940.450000000]: MessageFilter [target=base_footprint ]: Dropped 100.00% of messages so far. Please turn the [ros.rviz.message_notifier] rosconsole logger to DEBUG for more information.

I tried using the rosconsole tools to see this message, but it did not seem to exist on the rviz node.

<group ns="turtlebot">  
  <include file="$(find turtlebot_gazebo)/launch/includes/$(arg base).launch.xml">
    <arg name="base" value="$(arg base)"/>
    <arg name="stacks" value="$(arg stacks)"/>
    <arg name="3d_sensor" value="$(arg 3d_sensor)"/>
  <node pkg="robot_state_publisher" type="robot_state_publisher" name="robot_state_publisher">
    <param name="publish_frequency" type="double" value="30.0" />

I tried adding a static transform after noticing a break in the tf tree, but it did not resolve my problem.

   <node pkg="tf" type="static_transform_publisher" name="tf_gazebo_ns" args="0 0 0 0 0 0  turtlebot_base_footprint base_footprint 60"/>
edit retag flag offensive close merge delete


Thanks for asking here. I'm experiencing the same thing in RViz, when using a <robotnamespace>/cameras</robotnamespace> tag inside the camera sensor SDF in Gazebo7 with Baxter. Removing the /cameras namespace causes things to work. The real robot works regardless of namespace status.

imcmahon gravatar image imcmahon  ( 2017-02-07 15:23:25 -0500 )edit

Which version of ROS are you using? Are you using Gazebo or a real turtlebot?

imcmahon gravatar image imcmahon  ( 2017-02-07 15:24:24 -0500 )edit

Oh, should've included that: indigo and simulating in gazebo.

ljarin gravatar image ljarin  ( 2017-02-07 15:42:02 -0500 )edit

This is likely a bug in RViz or gazebo_ros_pkgs. I'm digging through some of the code now, but we'll likely need to open an issue in one of those two repos.

imcmahon gravatar image imcmahon  ( 2017-02-07 16:18:43 -0500 )edit

Cool, thanks; let me know what you find.

ljarin gravatar image ljarin  ( 2017-02-07 16:56:20 -0500 )edit

did you find anything? I'm going to open an issue otherwise

ljarin gravatar image ljarin  ( 2017-02-15 15:47:47 -0500 )edit

Yep! I think I have the answer. This is a bug in gazebo_ros_plugins. I just haven't had an opportunity to generate a proper patch / issue. I'm handing my work off to Dave Coleman to properly patch. Thanks Dave!

imcmahon gravatar image imcmahon  ( 2017-02-17 12:12:48 -0500 )edit

Could you point me to where it is? For my edification. Thanks again!

ljarin gravatar image ljarin  ( 2017-02-17 12:32:33 -0500 )edit