turning off hardware acceleration for rviz/hector quadrotor help

asked 2015-06-05 19:28:06 -0500

creative_cimmons gravatar image

Hello,

I am using ROS indigo on ubuntu 14.04 on virtualbox. Having set optimal settings in virtualbox (windows 8.1 host) ( enable 3d acceleration, using vguests addition ...) I have what I believe near optimal performance for the guest os. But when it comes to rviz

when I do rosrun rviz rviz

It spits out few errors such as vboxvideo not found and it outputs segementation fault core dumped and rviz exits.

Now the workaround given was it do export LIBGL_ALWAYS_SOFTWARE=1.

It is great for rviz but when running intensive applications which uses rviz like hector quadrotor,, this advice falls flat. The quadrotor is simply too slow.

If I didn't do the workaround, for rviz i get a segementation fault and for hector I get virtualbox referenced wrong memory address,, which is basically the same..

Is there any way where I could keep hardware acceleration and run rviz OR basically run hector on any other channel(you name it , I follow it)

thanks

edit retag flag offensive close merge delete

Comments

I'd say that the performance of your VM is not enough to run all of this at the same time. The errors you mention seem to indicate that "enable(d) 3D acceleration" was not successful, so I'd try and see whether you can solve that first. That should free some CPU for Gazebo and the physics sim.

gvdhoorn gravatar imagegvdhoorn ( 2015-06-06 08:08:33 -0500 )edit