Ask Your Question
0

turtlebot_arm, no motion plan found error

asked 2015-06-08 13:03:22 -0500

Nouman Tahir gravatar image

updated 2015-07-01 04:57:07 -0500

image description I m trying to use turtlebot_arm package for ROS hydro. it runs perfect with setting start and end state in rviz workspace but when i run the pick and place code it gives me this error...

"[ WARN] [1433588765.336846927]: Fail: ABORTED: No motion plan found. No execution attempted."

i have searching over the internet but couldnt find any solution to this issue i even tried on indigo but same problem occurs..

edit retag flag offensive close merge delete

1 Answer

Sort by ¬Ľ oldest newest most voted
0

answered 2015-06-08 15:40:28 -0500

jorge gravatar image

Hi, probably you hit over this issue. To verify this, please check the moveit's log and look for messages saying something ¨Orientation constraint violated ..."

If this is your problem, you need either to

a) modify moveit code as I did b) try this workaround

good luck!

btw, I improved turtlebot_arm greatly on indigo.... you cannot use it instead of hydro?

edit flag offensive delete link more

Comments

i have tried in indigo as well but facing same error. the issues you linked plans the path in some way but my arm does not plan any path at all, all it does with pick and place code is goes from home to rest pose

Nouman Tahir gravatar image Nouman Tahir  ( 2015-06-09 01:19:20 -0500 )edit

There are not turtlebot_arm hydro branch, so I understand you are running indigo devel code on hydro, right? Are you trying the running moveit demo? In emulation or with real robot (should not make any difference)

jorge gravatar image jorge  ( 2015-06-10 14:38:30 -0500 )edit

Running "roslaunch turtlebot_arm_moveit_config demo.launch" and then "rosrun turtlebot_arm_moveit_demos pick_and_place.py" works for me, so I need more details to reproduce the problem

jorge gravatar image jorge  ( 2015-06-10 15:15:30 -0500 )edit

Yes, I m running it on hydro but even in indigo it fails with same error meassage and I m trying in simulation only I couldn't find any source to buy it up till now, plz let me know if u know any source.

Nouman Tahir gravatar image Nouman Tahir  ( 2015-06-11 04:01:35 -0500 )edit

When you start "roslaunch turtlebot_arm_moveit_config demo.launch" without arguments, it starts a "fake" arbotix controller that just mover the arm model on RViz, so you can run pick and place demo without a real robot. Of course this is not a simulation, but is an easy start.

jorge gravatar image jorge  ( 2015-06-11 05:29:52 -0500 )edit

That said, I can simulate the arm on Gazebo. LAunch and config files are here. But I would rather try to fix the planning problem just starting moveit with a "fake" arm, as explained in my previous comment

jorge gravatar image jorge  ( 2015-06-11 05:32:33 -0500 )edit

in my case, i dont have real arm at all, i have clone turtlebot arm from github and built is using catkin_make after resolving arbotix and dependencies and using the hydro version of moveit. even running the pick and place with demo.launch doesnot work. p.s. moveit pr2 tutorial codes runs fine

Nouman Tahir gravatar image Nouman Tahir  ( 2015-07-01 04:39:38 -0500 )edit

please do refer to screenshot I posted

Nouman Tahir gravatar image Nouman Tahir  ( 2015-07-01 04:57:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2015-06-08 13:03:22 -0500

Seen: 1,362 times

Last updated: Jul 01 '15