ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
2

Rviz: Fixed frame [Map] does not exist

asked 2015-11-21 16:05:32 -0600

Cagurtay gravatar image

updated 2015-11-23 13:01:18 -0600

Hello,

I am trying to do this tutorial Writing A Global Path Planner As Plugin in ROS and i finally managed to get to last step, to simulate on Gazebo. After using roslaunch relaxed_astar test.launch and roslaunch turtlebot_rviz_launchers view_navigation.launch --screen Gazebo opens but I get an error :

Fixed frame [Map] does not exist

image description

Any ideas?

Thank you.

Edit: My map files:

image: my_map.pgm
# a 584 X 526 map @ 0.100 m/cell
resolution: 0.1
origin: [-18, -15, 0.0]
occupied_thresh: 0.65
free_thresh: 0.196
negate: 0

Map

My launch file :

<launch>
<include file="/opt/ros/indigo/share/turtlebot_bringup/launch/minimal.launch"></include>

  <include file="/opt/ros/indigo/share/turtlebot_bringup/launch/3dsensor.launch">
    <arg name="rgb_processing" value="false" />
    <arg name="depth_registration" value="false" />
    <arg name="depth_processing" value="false" />
    <arg name="scan_topic" value="/scan" />
  </include>

  <!-- Map server -->
  <arg name="map_file" default="/home/cagurtay/catkin_ws/src/relaxed_astar/maps/my_map.yaml"/>
  <node name="map_server" pkg="map_server" type="map_server" args="$(arg map_file)" />

  <arg name="initial_pose_x" default="0.0"/>
  <arg name="initial_pose_y" default="0.0"/>
  <arg name="initial_pose_a" default="0.0"/>
  <include file="/opt/ros/indigo/share/turtlebot_navigation/launch/includes/amcl.launch.xml">
    <arg name="initial_pose_x" value="$(arg initial_pose_x)"/>
    <arg name="initial_pose_y" value="$(arg initial_pose_y)"/>
    <arg name="initial_pose_a" value="$(arg initial_pose_a)"/>
  </include>

  <!-- Move base -->
  <include file="/opt/ros/indigo/share/turtlebot_navigation/launch/includes/move_base.launch.xml"/>

</launch>
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
4

answered 2015-11-23 00:48:35 -0600

YingHua gravatar image

Hi,

Have you ever change the Fixed frame? Maybe you can try this command as below.

rosrun tf static_transform_publisher 0.0 0.0 0.0 0.0 0.0 0.0 map my_frame 100

Alyson

edit flag offensive delete link more

Comments

I don't even know how to change it. I tried your solution, it fixes "Global Status" but there still is RobotModel error: Screenshot

Cagurtay gravatar image Cagurtay  ( 2015-11-23 03:36:12 -0600 )edit

Hi there! I am getting the exact same error and screenshot you sent. Are you able to solve it?

Rayner gravatar image Rayner  ( 2017-01-25 23:56:48 -0600 )edit

I also had this issue and believe the static tf fixed it.

cmfuhrman gravatar image cmfuhrman  ( 2018-03-07 13:09:33 -0600 )edit
0

answered 2018-03-26 21:28:27 -0600

Will Chamberlain gravatar image

It's always worth restarting RViz after updating map-related settings and/or your tf-tree : RViz does not always pick up these changes.

edit flag offensive delete link more
0

answered 2015-11-23 12:37:31 -0600

Looks like AMCL is not running properly. Could you add the content of your roslaunch relaxed_astar test.launch file? Does it contain all of this?:

You must now bringup your turtlebot. You need to launch minimal.launch, 3dsensor.launch, amcl.launch.xml and move_base.launch.xml. Here is an example of launch file that can be used for this purpose.

edit flag offensive delete link more

Comments

I added my launch file. It looks like it contains all of them. I just copy-pasted from the tutorial, changed map location.

Cagurtay gravatar image Cagurtay  ( 2015-11-23 13:02:43 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-11-21 16:01:41 -0600

Seen: 19,191 times

Last updated: Mar 26 '18