URDF generated by SW2URDF fails planning in MoveIt

asked 2017-01-07 08:09:35 -0600

t27 gravatar image

I am using the sw_urdf_exporter plugin to generate a URDF file for my custom 5-dof robot. The plugin worked correctly and I was able to preview the URDF and even move the joints using the sample urdf_tutorials viewer. I generated a MoveIt config for the same, using the MoveIt setup assistant and I was able to load up the standard demo.launch file from the moveit config as well. RViz showed the robot prefectly.

The problem I faced was that I was not able to plan the trajectories reliably, I could only succesfully plan about 1-2 out of every 10 attempts. Even a few simple trajectories failed. I though this could be an issue with the KDL solver, but even IKfast, the alternate solver failed.(Check this question for details).

Now, just to ensure that there is no issue in my robot configuration, I built a URDF file by hand. I ensured that my joint configuration remained the same. This URDF worked flawlessly and almost all plans worked pretty fine. Even with the default KDL solver.

This tells me that there could have been an issue with the sw_urdf_exporter plugin. I am using solidworks 2013(the version recommended). My design is also pretty simple.

Has anybody got the plugin to generate a urdf which works reliably with MoveIt and planning? How can I debug what could have gone wrong in the URDF generation? I can provide both the generated and the handwritten URDFs if it would help someone.

edit retag flag offensive close merge delete


Can you provide the links for both the urdf files?

bhavyadoshi26 gravatar image bhavyadoshi26  ( 2017-01-30 09:21:11 -0600 )edit