ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Gazebo tag <disableFixedJointLumping> didn't work

asked 2017-01-03 21:57:23 -0500

linhongbin gravatar image

Hi all,

I am trying to apply force torque sensor plugin in a fixed joint in Gazebo. I am trying to use the tag


But It didn't work.

<gazebo reference="FT_Top_Joint_right">

<gazebo reference="FT_Top_Joint_right">

<joint name="FT_Top_Joint_right" type="fixed">
   <origin xyz="0.00085087 -0.00087515 -0.0030305" rpy="3.1416 5.017E-16 1.5708" />
  <parent link="FT_right" />
  <child link="FT_Top_Plate_right" />


[FATAL] [1483501801.768755712, 0.347000000]: gazebo_ros_ft_sensor plugin error: jointName: FT_Top_Joint_right does not exist

So I found that disableFixedJointLumping didn't work.

I know that the "disableFixedJointLumping" option has been solved here osrf/sdformat/pull-requests/133/added-urdf-gazebo-extension-option-to/diff, but I still don't know how to update the urdf_parser.

I am using the OS: Ubuntu 14.04 , ROS version: indigo , Gazebo version: 2.2


edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2017-02-27 11:12:34 -0500

Silvio Traversaro gravatar image

The disableFixedJointLumping option was added in sdformat 2.0, while Gazebo 2 uses sdformat 1.x [1]. If you want to use the disableFixedJointLumping option, please use a more recent version of Gazebo as documented in .

[1] :

edit flag offensive delete link more


What is the option for Gazebo 9?

CroCo gravatar image CroCo  ( 2023-05-13 05:14:39 -0500 )edit

answered 2018-04-08 02:46:20 -0500

khaled0000 gravatar image

hi dont disable any thing just make type of joint "revolute" and give it Limit ,like

"<limit velocity="6.5" effort="1000" lower="0" upper="0" />"

and it will work

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-01-03 21:57:23 -0500

Seen: 1,426 times

Last updated: Jan 03 '17