Use LMS511 on ROS!!

asked 2016-12-07 21:55:17 -0600

Aakash gravatar image

updated 2016-12-08 01:26:48 -0600

gvdhoorn gravatar image

I'm trying to use LMS511 with these drivers https://github.com/clearpathrobotics/... but when a launch the lms5xx.launch file using roslaunch I get this error

ERROR: I/O exception - SickLMS5xx::_setupConnection: socket error on connect()!

I'm connected via Ethernet.

PLease help!

edit retag flag offensive close merge delete

Comments

That launch file has a parameter for the IP that your sensor is using:

<param name="ip_add" value="192.168.1.14" />

Have you set that to the correct value?

gvdhoorn gravatar imagegvdhoorn ( 2016-12-08 01:27:27 -0600 )edit

How to get the right value? @gvdhoom!

Aakash gravatar imageAakash ( 2016-12-08 05:50:09 -0600 )edit

How have you configured the sensor? You should be able to figure out the IP of the sensor that way.

gvdhoorn gravatar imagegvdhoorn ( 2016-12-08 06:12:16 -0600 )edit

I'm using the factory settings. I did not configured it so the IP I used till now was as mentioned in the manual i.e 192.168.0.1 I configured my pc's ip to 192.168.0.10 . Is that alright @gvdhoom...

Aakash gravatar imageAakash ( 2016-12-08 06:43:55 -0600 )edit

So, have you updated the value of ip_add in the launchfile to 192.168.0.1?

gvdhoorn gravatar imagegvdhoorn ( 2016-12-08 09:07:47 -0600 )edit

Yes! @gvdhoom I can even see my laptop being connected to it via that lan connection double arrow symbol!

Aakash gravatar imageAakash ( 2016-12-08 11:18:23 -0600 )edit