Strange error when using a new Hokuyo sensor-- Installation error [closed]

asked 2014-05-13 06:12:50 -0500

Vegeta gravatar image

Dear All,

I am having this strange error message when I tried to use another Hokuyo Sensor (UHG-08LX), the range of this sensor is 8m and FOV of 270 degrees, with frequency of 30 Hz (Specifications of UHG-08LX ). I replaced this with Hokuyo URG-04LX for mapping. I am using ROS fuerte, Ubuntu 12.04. I did checked whether the device is properly connected. I did the tutorial before operating referring the link here

But every time I run hokuyo.launch file I get this error message after it subscribe to the hokuyo messages:

[ WARN] [1356005675.931956581]: The use_rep_117 parameter has not been specified and has been automatically set to true.  This parameter will be removed in Hydromedusa.  Please see:
 [ERROR] [1356005680.166530146]: Exception thrown while opening Hokuyo.timeout reached (in hokuyo::laser::laserReadline) You may find further details at

Also, when using another hokuyo sensor (Hokuyo UBG-04LX-F01- Rapid), the same message appears. Both sensors have a high frequency rate.

What could be the problem. Does ROS does not allow new hokuyo sensors to be connected. Or do I have to register the new device everytime I use them. Please help me with this. I am planning to use a better sensor for mapping. I have no problems using the hokuyo 04LX sensor so far.

Thank you

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-11-02 01:42:22.298895