Ask Your Question
1

Need help install gazebo

asked 2016-11-18 01:02:17 -0500

Thang Nguyen gravatar image

updated 2016-11-19 00:37:38 -0500

I am using jetson tx1. I could not install the full package of ros indigo only the base package so now I have to install gazebo separately. I am following the steps to install from tutorial but I have problem. First I don't have curl

ubuntu@tegra-ubuntu:~/Documents$ curl -ssL http://get.gazebosim.org | sh
bash: curl: command not found

So I tried to install curl but I also have problem when install this:

ubuntu@tegra-ubuntu:~/Documents$ sudo apt-get install curl
[sudo] password for ubuntu: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 curl : Depends: libcurl3 (= 7.35.0-1ubuntu2.10) but 7.35.0-1ubuntu2.6 is to be installed
 libpcre3-dev : Depends: libpcre3 (= 1:8.31-2ubuntu2.3) but 2:8.35-7.1ubuntu1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
ubuntu@tegra-ubuntu:~/Documents$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 libpcre3-dev : Depends: libpcre3 (= 1:8.31-2ubuntu2.3) but 2:8.35-7.1ubuntu1 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

I don't know what should I do next. Please give me an advice.

Thank you very much.

Edit 1: Below is what happen if I install Pre-Built Debians

ubuntu@tegra-ubuntu:~/Documents$ sudo apt-get install ros-indigo-gazebo-ros-pkgs ros-indigo-gazebo-ros-control
[sudo] password for ubuntu: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-indigo-gazebo-ros-pkgs
E: Unable to locate package ros-indigo-gazebo-ros-control

Edit 2: Alternative Installation ( http://gazebosim.org/tutorials?tut=in... ) When I come to: sudo apt-get install gazebo7 I don't think I should install gazebo7 because it says that Indigo should go with gazebo2. Then I got

ubuntu@tegra-ubuntu:~/Documents$ sudo apt-get install gazebo2  2
[sudo] password for ubuntu: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package gazebo2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'gazebo2' has no installation candidate
edit retag flag offensive close merge delete

Comments

Have you tried the Alternate Installation? It does not require curl.

JoshMarino gravatar imageJoshMarino ( 2016-11-18 21:49:37 -0500 )edit

Josh, I have just added the edit 2 about alternative installation. It says gazebo7 but I would like to install gazebo2.

Thang Nguyen gravatar imageThang Nguyen ( 2016-11-19 00:40:24 -0500 )edit

Gazebo2 is from packages.ros.org whereas the link I gave is for packages.osrfoundation.org , Gazebo 4-7. Might be able to follow same steps, but replacing the source location.

JoshMarino gravatar imageJoshMarino ( 2016-11-19 17:01:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-11-19 01:27:47 -0500

I would like to know about the operating system. Are you using Linux 14.04 or what? I have gone through experience in Raspberry Pi 3. Initially, I installed debian package and I was facing lots of problems. Then I removed it and installed ubuntu mate and in it, I installed everything the desktop package of ROS and it worked perfectly. Jetson TX1 is a high specification system and it would run with no problem even if you install Desktop package. Installing individual packages will always create problems because many times you will need many different packages. That's my experience.

edit flag offensive delete link more

Comments

1

Yes, I am using Ubuntu 14.04. So you mean that I should reinstall ROS full? The problem is at the time I install ROS, I cannot install the full package version, I don't remember why. I may have to try it again.

Thang Nguyen gravatar imageThang Nguyen ( 2016-11-19 07:15:15 -0500 )edit

Yes. Install Desktop version and please first install ubuntu mate. Otherwise, desktop package option will not be available. All the best.

Dr Abdul Mannan gravatar imageDr Abdul Mannan ( 2016-11-21 09:07:16 -0500 )edit
1

Dr Abdul: I believe that I installed the desktop version but I have not installed ubuntu mate yet. Maybe this the reason.

Thang Nguyen gravatar imageThang Nguyen ( 2016-11-21 10:26:34 -0500 )edit

Dr Abdul: I don't understand why I need Ubuntu mate. Could you please tell me more detail about this?

Thang Nguyen gravatar imageThang Nguyen ( 2016-11-22 06:54:44 -0500 )edit

I have a bad experience about different operating system. In particular, I used Raspbian. It was not good. It was giving me lots of errors when I was using ROS and used to take a really long time to build package. When I used ubuntu mate, I did not have these problems.

Dr Abdul Mannan gravatar imageDr Abdul Mannan ( 2016-11-25 00:33:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-11-18 01:02:17 -0500

Seen: 770 times

Last updated: Nov 19 '16