Ask Your Question
0

Messagefilter dropped 100% of messages

asked 2016-11-01 04:06:19 -0500

gijsje170 gravatar image

updated 2016-11-01 05:47:27 -0500

When launching the navigation stack (gmapping and movebase) I will frequently receive the following message:

[ WARN] [1477990695.164889638]: MessageFilter [target=odom ]: Dropped 100.00% of messages so far. Please turn the [ros.costmap_2d.message_notifier] rosconsole logger to DEBUG for more information.
[ WARN] [1477990695.175311684]: MessageFilter [target=map ]: Dropped 100.00% of messages so far. Please turn the [ros.costmap_2d.message_notifier] rosconsole logger to DEBUG for more information.

When looking at my tf tree i see the following information. image description

I will update this post with rosconsole logger to debug information soon. The following message is given:

[DEBUG] [1299740216.768663556, 1299651571.155978846]: MessageFilter [target=/odom ]: Removed oldest message because buffer is full, count now 5 (frame_id=camera_depth_frame, stamp=1299651570.618031)

[DEBUG] [1299740216.768820286, 1299651571.155978846]: MessageFilter [target=/odom ]: Added message in frame laser at time 1299651571.154, count now 5
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2016-11-01 05:55:25 -0500

gijsje170 gravatar image

updated 2016-11-01 05:56:13 -0500

The problem can be found in the debug. It is in frame_id=camera_depth_frame. I came to this conclusion thanks to this post: gmapping-works-in-gazebo-but-not-on-robot

When running

rosrun tf static_transform_publisher 0 0 0 0 0 0 base_link camera_depth_frame 100

my problems were solved.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-01 04:06:19 -0500

Seen: 12,910 times

Last updated: Nov 01 '16