TF of URDF is not showing from robot state publisher

asked 2016-10-23 15:45:28 -0500

Kishore Kumar gravatar image

I am using raspberry pi and trying to publish TF of URDF file. I created a URDF of a differential drive robot and wrote the launch file including joint state publisher & robot state publisher to publish the TF. When i run the launch file and tried to read the TF using tf_monitor, there is no TF value shown, below is my result. When i run rostopic echo tf_static the topic is publishing.

image description

The strange part is when i tried this in my local PC (with same URDF & launch) the result was perfect, TF of all the links published. Is there any limitation in raspberry pi to publish robot state of URDF? How to resolve this?

edit retag flag offensive close merge delete

Comments

Did you ever find a solution to this? I'm seeing the same issue (missing TF between some links). In my case, the links that don't show up have no collision geometry (not sure if that matters).

Rick Armstrong gravatar imageRick Armstrong ( 2017-08-06 21:00:56 -0500 )edit