Ask Your Question
0

Odometry first check failed in Navigation Tuning guide

asked 2016-09-25 16:15:03 -0600

Dharmateja Kadem gravatar image

As stated in Navigation tuning guide http://wiki.ros.org/navigation/Tutori...

[The first test checks how reasonable the odometry is for rotation. I open up rviz, set the frame to "odom," display the laser scan the robot provides, set the decay time on that topic high (something like 20 seconds), and perform an in-place rotation. Then, I look at how closely the scans match each other on subsequent rotations. Ideally, the scans will fall right on top of each other, but some rotational drift is expected, so I just make sure that the scans aren't off by more than a degree or two.]

what to do if this test fails? I have an error of 10 degrees when the above test is performed. How to reduce this error so that the scans aren't off by more than a degree or two?

The second test i.e., for translation its working fine. The problem is only when it is rotating.

Someone please help me with this problem. Thanks

I am using Ubuntu 14.04, Ros indigo and it is a differential drive robot.

edit retag flag offensive close merge delete

Comments

I wouldn't say 10 degrees is a complete failure. If your kinematics model was really wrong, you would be seeing massive discrepancies between successive laser scans (90, 180, or even more, degrees). So, double-check your model. Maybe the wheel base is a bit off.

spmaniato gravatar imagespmaniato ( 2016-09-25 16:56:54 -0600 )edit

I think wheel base is ok because its working fine when there is a linear motion

Dharmateja Kadem gravatar imageDharmateja Kadem ( 2016-09-25 17:04:35 -0600 )edit
1

The wheel base (i.e., the distance between the two wheels) does not enter the linear motion calculations, only the angular. Maybe you're confusing it with the wheel radius?

spmaniato gravatar imagespmaniato ( 2016-09-25 17:36:43 -0600 )edit

Thanks it worked

Dharmateja Kadem gravatar imageDharmateja Kadem ( 2016-09-26 12:03:29 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-09-25 21:40:37 -0600

If the problem is only when rotating then, as suggested by @spmaniato, you need to adjust your robot's wheel base (distance between wheels) parameter on your kinematic model.

From what I remember when I had to calibrate my robot's odometry, if your angular error grows clockwise you need to reduce the wheel base parameter. If the angular error grows counterclockwise then increase the parameter (might be the other way round :P)

Good luck!

edit flag offensive delete link more

Comments

Thanks it worked

Dharmateja Kadem gravatar imageDharmateja Kadem ( 2016-09-26 12:03:13 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-09-25 16:15:03 -0600

Seen: 206 times

Last updated: Sep 25 '16