ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

How to Install ROS Kinetic Ubuntu 16.04

asked 2016-09-16 22:13:40 -0600

yodigi7 gravatar image

updated 2016-10-20 05:22:22 -0600

gvdhoorn gravatar image

After trying to install ROS following the instructions here.

After finally entering this command:

sudo apt-get install ros-kinetic-desktop-full

I was presented with this error:

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:  ros-kinetic-desktop-full :

Depends: ros-kinetic-desktop but it is not going to be installed

Depends: ros-kinetic-perception but it is not going to be installed

Depends: ros-kinetic-simulators but it is not going to be installed E: Unable to correct problems, you have held broken packages.
edit retag flag offensive close merge delete


I'm having the same problem -- tried following Davide Faconti's solution, and it didn't help.

jdmartin86 gravatar image jdmartin86  ( 2016-12-19 09:39:33 -0600 )edit

I have same problem and tried everythings but no luck!

Qinsheng gravatar image Qinsheng  ( 2017-09-23 08:54:07 -0600 )edit

7 Answers

Sort by » oldest newest most voted

answered 2016-12-28 09:13:10 -0600

klindgren gravatar image

Hi Yodigi,

I had the same problem with the exact same three depends messages after upgrading to 16.04. When you run

sudo apt-get update && sudo apt-get upgrade

do you get a message about packages being "held back"? I fixed my issue by running

sudo apt-get install < packages-held-back >

which installs the packages and all of its dependencies. From what I've read, individually installing the packages is safer than running

sudo apt-get dist-upgrade

I also had an issue with openni not configuring but the following commands solved the issue

sudo apt-get remove libopenni0

sudo apt-get purge libopenni*

and finally, running

sudo apt-get install ros-kinetic-desktop-full

ran successfully.

edit flag offensive delete link more



this worked for me sudo apt-get dist-upgrade thankyou

youssef desouky gravatar image youssef desouky  ( 2020-07-15 02:08:40 -0600 )edit

answered 2017-07-05 15:39:56 -0600

tekin gravatar image

I had the exact same problem and solved it by installing The Four Main Repositories:

  1. Main - Canonical-supported free and open-source software.
  2. Universe - Community-maintained free and open-source software.
  3. Restricted - Proprietary drivers for devices.
  4. Multiverse - Software restricted by copyright or legal issues.

To install these repositories one method is to go through the "Ubuntu Software Center". Open the software center, then from the Edit menu select "Software Sources" and select checkboxes next to the repository names. Complete Instruction can be found here:

However, when I controlled the "Ubuntu Software Center" these repositories were already checked! When I tried to close the window it throw an error that cannot update. I solved that problem by changing the Download From to Main Server.

edit flag offensive delete link more


it makes work "sudo apt-get install ros-kinetic-desktop-full". Thanks!!

zedrone gravatar image zedrone  ( 2018-10-25 04:19:36 -0600 )edit

Under System Settings->Software & Updates,

checking everything under Ubuntu Software, Other Software,Updates

then running sudo apt-get install ros-kinetic-desktop-full

worked for me.

espkh4 gravatar image espkh4  ( 2019-01-26 22:13:17 -0600 )edit

answered 2018-01-09 12:32:37 -0600

asthma gravatar image

I had the exact same issue. I solved it by tracking down the dependencies that caused this. I did this by asking one of the unmet dependencies to be be installed. You do this multiple times to go deeper in the dependency chain. At the end I found out that qt5 was the issue. I ran sudo apt-get purge '.*qt5*.' and ran sudo apt-get install ros-kinetic-desktop-full again. It worked.

edit flag offensive delete link more


Your answer saved me, thank you!

Raisintoe gravatar image Raisintoe  ( 2018-08-30 20:34:00 -0600 )edit

Did not work for me :/

Jägermeister gravatar image Jägermeister  ( 2018-10-10 08:29:00 -0600 )edit

answered 2017-08-18 06:50:48 -0600

drewm1980 gravatar image

aptitude is very useful for this. In my case I had to say no to a handful of aptitude's proposed solutions, but eventually it offered to downgrade qt5, and that seems to have worked.

edit flag offensive delete link more


This worked for me. Thx!

jungx148 gravatar image jungx148  ( 2020-11-09 21:28:54 -0600 )edit

answered 2018-10-26 21:36:07 -0600

willIamxue96 gravatar image

Well, I recommend you to install this "dependencies", and do it over and over again, to find out what kind of package that blocks your installtion.

In my case, I realized "ros-kinetic-simulators" was blocked by "ros-kinetic-gazebo-ros-pkgs" which depends on "ros-kinetic-gazebo-dev", "ros-kinetic-gazebo-plugins" and "ros-kinetic-gazebo-ros". Then I installed "ros-kinetic-gazebo-dev", after getting wrong answer on "gazebo7" and "libgazebo7-dev", and noticed that gazebo9 I installed conflicted with gazebo7 which required by "ros-kinetic-desktop-full".

Eventually, I removed gazebo9 and everthing worked fine!

edit flag offensive delete link more

answered 2018-04-17 21:57:24 -0600

pan gravatar image

it works for me, try with link:

edit flag offensive delete link more



@pan Please don't just post a link to an external site as an answer. If/when that site disappears then the this answer won't be able to help anyone. Please include the steps here to make this a complete answer.

jayess gravatar image jayess  ( 2018-04-18 00:42:52 -0600 )edit

Does not work either.

Jägermeister gravatar image Jägermeister  ( 2018-10-10 08:47:56 -0600 )edit

answered 2016-10-20 04:47:04 -0600

Davide Faconti gravatar image

I have given an answer that MIGHT help you here

edit flag offensive delete link more

Question Tools


Asked: 2016-09-16 22:13:40 -0600

Seen: 24,535 times

Last updated: Oct 26 '18