Ask Your Question
0

Moveit Setup Assistant Package Missing

asked 2016-08-12 09:49:47 -0500

bhavyadoshi26 gravatar image

I installed the Moveit! package following this link.

Then I moved to the Setup Assistant but I encountered the following problem :

:~$ roslaunch moveit_setup_assistant setup_assistant.launch
[setup_assistant.launch] is neither a launch file in package [moveit_setup_assistant] nor is [moveit_setup_assistant a launch file name
The traceback for the exception was written to the log file

When I tried to check if the package moveit_setup_assistant exists, this is what it showed :

:~$ rospack find moveit_setup_assistant
[rospack] Error: package 'moveit_setup_assistant' not found

I have tried to search for answers but I haven't been able to find any. From this link it seems like they have aborted the setup_assistant package for Jade.

Any solutions to this problem?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-11-23 11:06:36 -0500

ZainMehdi gravatar image

updated 2016-11-23 11:06:53 -0500

You need to run sudo apt-get update first and then enter following command as mentioned here

sudo apt-get install ros-jade-moveit
source /opt/ros/jade/setup.bash

I had a similar issue with jade but following above instructions I solved them. Hope it helps

edit flag offensive delete link more
0

answered 2016-08-15 08:50:28 -0500

ghkraju gravatar image

This package can be downloaded from the following link:

https://github.com/ros-planning/movei...

You can build this package from the local catkin_workspace using "catkin_make".

Note: In some scenarios, the dependent packages will be missing from your PC. As far as i know we need "FCL" for this.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-12 09:49:47 -0500

Seen: 1,203 times

Last updated: Nov 23 '16