Ask Your Question
0

MoveIt setup assistant symbol lookup error while loading model [closed]

asked 2016-06-29 04:04:49 -0500

Marcel Usai gravatar image

Hi,

Today I wanted to load an old robot model into the moveit_setup_assistant. I tried several models, all of which I once could easily load, but all of them failed the same way:

process[moveit_setup_assistant-1]: started with pid [6819]

(moveit_setup_assistant:6819): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(moveit_setup_assistant:6819): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
[ INFO] [1467190832.819020263]: Loaded item_table robot model.
[ INFO] [1467190832.819146906]: Setting Param Server with Robot Description
[ INFO] [1467190832.834453095]: Robot semantic model successfully loaded.
[ INFO] [1467190832.834526040]: Setting Param Server with Robot Semantic Description
[ INFO] [1467190832.858036026]: Loading robot model 'item_table'...
[ INFO] [1467190832.858102899]: No root joint specified. Assuming fixed joint
[ INFO] [1467190833.314165918]: Stereo is NOT SUPPORTED
[ INFO] [1467190833.314333604]: OpenGl version: 3 (GLSL 1.3).
/opt/ros/indigo/lib/moveit_setup_assistant/moveit_setup_assistant: symbol lookup error: /opt/ros/indigo/lib/libmoveit_setup_assistant_widgets.so: undefined symbol: _ZN4rviz20VisualizationManagerC1EPNS_11RenderPanelEPNS_22WindowManagerInterfaceEN5boost10shared_ptrIN2tf17TransformListenerEEE
================================================================================REQUIRED     process [moveit_setup_assistant-1] has died!
process has died [pid 6819, exit code 127, cmd /opt/ros/indigo/lib/moveit_setup_assistant/moveit_setup_assistant __name:=moveit_setup_assistant __log:=/home/marcel/.ros/log/6304d61a-3dc8-11e6-aab6-5404a6f2a4cf/moveit_setup_assistant-1.log].
log file: /home/marcel/.ros/log/6304d61a-3dc8-11e6-aab6-5404a6f2a4cf/moveit_setup_assistant-1*.log
Initiating shutdown!
================================================================================
[moveit_setup_assistant-1] killing on exit

I reinstalled all moveit packages, still same error. Has anybody an idea?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Marcel Usai
close date 2016-07-11 10:56:01.264913

Comments

Do you have any outstanding ROS-related updates? Binary compatibility is not always guaranteed between builds / syncs in ROS, so upgrading only parts of it can result in strange errors and failures.

gvdhoorn gravatar image gvdhoorn  ( 2016-06-29 04:36:26 -0500 )edit

No, I installed all updates. Then, because it was still not working, I removed and reinstalled all moveit packages.

Marcel Usai gravatar image Marcel Usai  ( 2016-07-08 10:02:09 -0500 )edit

Is it possible that this error is related to OpenGL?

Marcel Usai gravatar image Marcel Usai  ( 2016-07-08 12:52:31 -0500 )edit
1

I doubt it. Sounds more like a mismatch between the main MSA binary and some of its shared libraries. The symbol demangled is: rviz::VisualizationManager::VisualizationManager(rviz::RenderPanel*, rviz::WindowManagerInterface*, boost::shared_ptr<tf::TransformListener>). Are all your pkgs up2date?

gvdhoorn gravatar image gvdhoorn  ( 2016-07-09 04:23:17 -0500 )edit

Also: what platform, how did you install ROS, compiler versions, etc.

gvdhoorn gravatar image gvdhoorn  ( 2016-07-09 04:23:41 -0500 )edit

I think you nailed it! Because of an issue with RVIZ some time ago, I still have it in my own workspace and therefore did not get any updates. Will try with updated RVIZ pkg on monday!

Marcel Usai gravatar image Marcel Usai  ( 2016-07-09 04:48:29 -0500 )edit

Yeah, as I wrote before: there is no binary compatibility guarantee between successive ROS updates, so you'll either have to not update anything or update everything. You can have overlays with different versions, but then you must rebuild whenever the .debs get updated.

gvdhoorn gravatar image gvdhoorn  ( 2016-07-09 05:44:07 -0500 )edit

Thank you, that was it. I updated my answer as well.

Marcel Usai gravatar image Marcel Usai  ( 2016-07-11 10:55:09 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-08 13:02:10 -0500

Marcel Usai gravatar image

updated 2016-07-11 10:54:41 -0500

The error was with RVIZ: I did not use the updated version because I had an older version sitting in my workspace (due to an older, already resolved issue). When not sourcing my workspace, everything works fine.

Using the latest RVIZ version resolved the error.

edit flag offensive delete link more

Comments

Hi, I got the same issue. What version of RVIZ works ? mine 1.11.3 crash with MoveIt Thanks

TomSon gravatar image TomSon  ( 2017-08-02 10:32:31 -0500 )edit

i use the latest version in indigo

Marcel Usai gravatar image Marcel Usai  ( 2017-08-15 01:57:15 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-06-29 04:04:49 -0500

Seen: 304 times

Last updated: Jul 11 '16