Ask Your Question
0

Unable to connect camera Basler TOF with pylon_camera

asked 2016-07-21 02:38:54 -0600

est_CEAR gravatar image

updated 2016-07-21 07:02:46 -0600

Hi, I am using a Basler camerawith ethernet cable and changed the IP of the camera. In the pylon SDF, I have to set the IP of the camera to find it. How can I do it in the ros driver pylon_camera?

Here is what I get when I don't set the IP:

$ roslaunch pylon_camera pylon_camera_node.launch
... logging to /home/heloise/.ros/log/6383e4a0-4f11-11e6-9849-0021cccedb44/roslaunch-ffrobotics-ThinkPad-T430-11741.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ffrobotics-ThinkPad-T430:40199/

SUMMARY
========

PARAMETERS
 * /pylon_camera_node/camera_frame: pylon_camera_node
 * /pylon_camera_node/camera_info_url: 
 * /pylon_camera_node/device_user_id: 
 * /pylon_camera_node/frame_rate: 5.0
 * /rosdistro: indigo
 * /rosversion: 1.11.20

NODES
  /
    pylon_camera_node (pylon_camera/pylon_camera_node)

auto-starting new master
process[master]: started with pid [11834]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 6383e4a0-4f11-11e6-9849-0021cccedb44
process[rosout-1]: started with pid [11853]
started core service [/rosout]
process[pylon_camera_node-2]: started with pid [11856]
[ INFO] [1469084683.612663561]: No Device User ID set -> Will open the camera device found first
GetDeviceDiscoveryInfo: bFunctionClass = 14, bFunctionSubClass = 3, bFunctionProtocol = 0. Device is not an U3V device.
[ERROR] [1469084684.724460264]: No camera present
GetDeviceDiscoveryInfo: bFunctionClass = 14, bFunctionSubClass = 3, bFunctionProtocol = 0. Device is not an U3V device.

Does "Device is not an U3V device" means that the driver works only with USB connection?

When I run /opt/pylon5/bin/PylonViewerApp to see the output of the camera, I only get a black screen, and the lights of the Basler camera don't light up. Any idea? What am I doing wrong?

EDIT My MTU was too small then the jumbo frames didn't pass. I increased my MTU to 8192 and now I got a screen without image in the PylonViewerApp, and the lights of the Basler camera still don't light up. In the terminal I still get:

GetDeviceDiscoveryInfo: bFunctionClass = 14, bFunctionSubClass = 3, bFunctionProtocol = 0. Device is not an U3V device.

The output of the Grab is:

SizeX: 666
SizeY: 738
Gray value of first pixel: 0

SizeX: 666
SizeY: 738
Gray value of first pixel: 1

That seems that the image is received somewhere, right?

When trying to launch the ROS driver, I get now:

[ INFO] [1469099731.455049422]: Trying to open the following camera: 107002
GetDeviceDiscoveryInfo: bFunctionClass = 14, bFunctionSubClass = 3, bFunctionProtocol = 0. Device is not an U3V device.
[ INFO] [1469099731.712534727]: Found the desired camera with DeviceUserID 107002: TOF_ES
[ERROR] [1469099731.871237166]: Error applying cam specific startup setting for GigE cameras: Feature not present (reference not valid)
[ERROR] [1469099731.871311700]: Error while applying the cam specific startup settings (e.g. mtu size for GigE, ...) to the camera!
[pylon_camera_node-2] process has finished cleanly
edit retag flag offensive close merge delete

Comments

IIRC, the GigE protocol doesn't use/need IPs, as the local subnet is scanned for compatible devices. You then typically select one of those by specifying a serial nr or device ID. The config/default.yaml file in the pylon_camera pkg has a device_user_id, which you should be able to use.

gvdhoorn gravatar imagegvdhoorn ( 2016-07-21 03:06:15 -0600 )edit

Whether the package is then compatible with your camera, I can't say. The Magazino devs frequent this board, so I expect one of them will respond. Alternatively, you could post an issue on the issue tracker.

gvdhoorn gravatar imagegvdhoorn ( 2016-07-21 03:07:18 -0600 )edit

Hi, thanks for your answer. I set the device ID in the parameters, but I get the error that I posted in my question

est_CEAR gravatar imageest_CEAR ( 2016-07-21 03:26:21 -0600 )edit

Could you give us some more information? Which camera are you using? Which IP have you assigned and how does your network look like? Can you get images with the PylonViewerApp? Do you have several cameras attached? It's nice to see our package in use :)

NEngelhard gravatar imageNEngelhard ( 2016-07-21 05:52:23 -0600 )edit
2

Based on:

When I run /opt/pylon5/bin/PylonViewerApp [..], I only get a black screen, and the lights of the Basler camera don't light up

I would say that, no, the PylonViewerApp also doesn't work :)

gvdhoorn gravatar imagegvdhoorn ( 2016-07-21 06:06:08 -0600 )edit

Oops. Didn't see that. In this case, the problem is probably not in the pylon_camera but in the setup of the camera. Is the camera at least listed as a GigE-Device in the PylonViewerApp?

NEngelhard gravatar imageNEngelhard ( 2016-07-21 06:11:12 -0600 )edit

Hi, I updated the question. I had an error of MTU

est_CEAR gravatar imageest_CEAR ( 2016-07-21 06:18:11 -0600 )edit

What camera model do you use?

NEngelhard gravatar imageNEngelhard ( 2016-07-21 06:20:52 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-07-21 06:30:49 -0600

Marcel Debout gravatar image
GetDeviceDiscoveryInfo: bFunctionClass = 14, bFunctionSubClass = 3, bFunctionProtocol = 0. Device is not an U3V device.

-> the driver tries to open your webcam, because in the c_device_list, this is listed above ;-)

Found the desired camera with DeviceUserID 107002: TOF_ES

The pylon_camera pkg does not support the Basler TOF-Camera

edit flag offensive delete link more

Comments

Really? So why did it change with the MTU size? I still don't see the output in the PylonViewerApp...

est_CEAR gravatar imageest_CEAR ( 2016-07-21 06:46:16 -0600 )edit

I get this message (GetDeviceDiscoveryInfo: bFunctionClass = 14, bFunctionSubClass = 3, bFunctionProtocol = 0. Device is not an U3V device.) while running the Pylon viewer too, even when I am connected to the Basler TOF camera

est_CEAR gravatar imageest_CEAR ( 2016-07-21 06:48:09 -0600 )edit

Yes, you will get the Device is not an U3V device message in any case, but this is not an error. While trying to open a camera, all possible devices are listed and checked if they fit the USB3 Vision or GigE Vision standard. The first one that fits will be opened in case no device_user_id is set

Marcel Debout gravatar imageMarcel Debout ( 2016-07-21 06:58:55 -0600 )edit

Could you set the device_user_id so that you select the camera to be opened?

NEngelhard gravatar imageNEngelhard ( 2016-07-21 07:28:54 -0600 )edit
1

yes, the camera was selected with the good ID that I set. See: Trying to open the following camera: 107002 and Found the desired camera with DeviceUserID 107002: TOF_ES

est_CEAR gravatar imageest_CEAR ( 2016-07-21 07:48:31 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-07-21 02:38:54 -0600

Seen: 1,074 times

Last updated: Jul 21 '16