Problem with spinning lidar in gmapping

asked 2016-06-29 10:11:32 -0500

b2meer gravatar image

I have set my lidar lite v2 spinning 360 degree on a stepper motor (since it is a range finder, not a wide angle scanner) and the transform base_link --> base_laser updates according to the motor position. So, when I run gmapping, I see my lidar rotating as I want it to be. But due to this, in Rviz, my robot keeps taking small jumps in the map due to which a proper map is not created (for example, a straight wall would become curved or bent). If I stop rotating my lidar (i.e. the transform base_link --> base_laser is constant), then the problem vanishes and the robot no more jumps around. I tried to resolve this problem by editing gmapping such that it always publishes map -- > odom transform as zero. By doing so, the robot does not jumps around anymore while lidar is rotating, but it leads to a new problem which I have asked in a new question in the following link. http://answers.ros.org/question/23842...

Any ideas how can I resolve this problem of robot jumping around when lidar is rotating ?

edit retag flag offensive close merge delete

Comments

did you solve the problem ? i have the same problem

marawy_alsakaf gravatar imagemarawy_alsakaf ( 2017-11-21 14:16:20 -0500 )edit