Ask Your Question
1

footprint doesnt move in the costmap

asked 2016-06-24 08:12:00 -0500

bsk gravatar image

Hello, for show obstacles in the map with only laser scanner i'm trying to do costmap_2d. when i move the laser, the footprint in the rviz doesnt move, it's always in its initial pose..is this normal? what can i do for make it move?

in rqt, when i choose Nodes/Topics (all) the footprint and costmap is corresponding each other, but when i choose Nodes/Topics (active) just see costmap to footprint (i'm sorry if i cant explain well)

image description

my costmap launch file:

<launch>

 #### connect to lms100 ###########################

  <param name="/use_sim_time" value="false"/>

 <node pkg="lms1xx" name="lms1xx" type="LMS1xx_node">
    <param name="host" value="169.254.10.200" />
 </node>

  #### publish an example base_link -> laser transform ###########

  <node pkg="tf" type="static_transform_publisher" name="base_link_to_laser" 
    args="0.0 0.0 0.0 0.0 0.0 0.0 /base_link /laser 40" />

 <node name="static_tf0" pkg="tf" type="static_transform_publisher" args="2 0 0 0 0 0 /map /base_link 100"/>


<!-- Run the map server -->
  <node name="map_server" pkg="map_server" type="map_server"  args="$(find laser_scan_matcher)/launch/mymap.yaml"/>

  <!-- Run the costmap node -->
  <node name="costmap_node" pkg="costmap_2d" type="costmap_2d_node" >
    <rosparam file="$(find laser_scan_matcher)/launch/mparams.yaml" command="load" ns="costmap" />
  </node>

</launch>

my params.yaml file:

global_frame: /map
robot_base_frame: base_link
update_frequency: 5.0
publish_frequency: 1.0

static_map: true

#begin - COMMENT these lines if you set static_map to true
rolling_window: false
width: 6.0
height: 6.0
resolution: 0.025
#end - COMMENT these lines if you set static_map to true

transform_tolerance: 0.3
obstacle_range: 2.5
max_obstacle_height: 2.0
raytrace_range: 3
footprint: [[-0.325, -0.325], [-0.325, 0.325], [0.325, 0.325], [0.46, 0.0], [0.325, -0.325]]
#robot_radius: 0.46
footprint_padding: 0.01
inflation_radius: 0.1
cost_scaling_factor: 10.0
lethal_cost_threshold: 100
observation_sources: base_scan
base_scan: {data_type: LaserScan,  sensor_frame: /laser,  topic: /scan, expected_update_rate: 0.4,
  observation_persistence: 0.0, marking: true, clearing: true, max_obstacle_height: 0.4, min_obstacle_height: 0}
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-06-24 09:43:59 -0500

bsk gravatar image

updated 2016-06-27 08:03:59 -0500

solved it. i think it was because of the static transformation. i used laser_scan_matcher to provide odom then i used transformation between odom and map...instead of <node name="static_tf0" pkg="tf" type="static_transform_publisher" args="2 0 0 0 0 0 /map /base_link 100"/>

i used <node pkg="tf" type="static_transform_publisher" name="map_to_odom" args="0.0 0.0 0.0 0 0 0.0 /map /odom 100"/>

any other solution is highly appreciated.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-24 08:12:00 -0500

Seen: 419 times

Last updated: Jun 27 '16