Ask Your Question
0

openni2_tracker configuration

asked 2016-04-01 18:32:00 -0500

joe.s gravatar image

I'm trying to configure the openni2_tracker package to use with my ASUS Xtion Pro but am having a little trouble. This is in Hydro on a 12.04 machine.

When performing a catkin_make, I get this error:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Nite2_INCLUDEDIR
   used as include directory in directory /home/joe/catkin_ws/src/openni2_tracker
Nite2_LIBRARY
    linked by target "openni2_tracker" in directory /home/joe/catkin_ws/src/openni2_tracker

-- Configuring incomplete, errors occurred!
make: *** [cmake_check_build_system] Error 1

I know that this points to the CMakeLists.txt file for the openni2_tracker package but don't understand where I'm supposed to go from here. This person has done something similar in step 4 but I'm not following. Any suggestions would be appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-04 03:00:08 -0500

Humpelstilzchen gravatar image

updated 2016-04-04 03:00:45 -0500

It wants you to set the environment variables NITE2_INCLUDE and NITE2_REDIST64 to the place where you installed Nite2 to. e.g.

export NITE2_INCLUDE=/usr/local/NiTE-Linux-x64-2.2/Include
export NITE2_REDIST64=/usr/local/NiTE-Linux-x64-2.2/Redist
edit flag offensive delete link more

Comments

(newbie question) sooo that means to add them to my .bashrc file? (and not the CMakeLists.txt file for openni2_tracker?)

joe.s gravatar imagejoe.s ( 2016-04-04 11:13:52 -0500 )edit

You need to execute the commands before catkin, adding them to .bashrc file (and loading it) is one way.

Humpelstilzchen gravatar imageHumpelstilzchen ( 2016-04-04 11:33:07 -0500 )edit

I'm not quite sure what you mean by "execute commands before catkin". What do you mean? But, adding those lines to the .bashrc and reloading the command prompt I get.

joe.s gravatar imagejoe.s ( 2016-04-04 13:28:54 -0500 )edit

I guess your comment is missing a few characters. Please read the documentation about environment variables

Humpelstilzchen gravatar imageHumpelstilzchen ( 2016-04-05 00:06:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-01 18:32:00 -0500

Seen: 208 times

Last updated: Apr 04 '16