Ask Your Question
0

Hash Sum mismatch while update package index(indigo/ubuntu 14.04.04)

asked 2016-03-07 20:51:00 -0600

hughie gravatar image

updated 2016-03-07 22:49:22 -0600

I followed install guide(http://wiki.ros.org/indigo/Installation/Ubuntu) while 1.4 Installation step(sudo apt-get update), I met this error.

W:Failed to fetch http://packages.ros.org/ros/ubuntu/dists/trusty/main/binary-amd64/Packages Hash Sum mismatch

And, the laptop can resolve the web page( http://packages.ros.org/ros/ubuntu/di... ).

I tried to fix it with below link, but it is not working.

http://askubuntu.com/questions/41605/...

edit retag flag offensive close merge delete

Comments

Ubuntu 14.04.03 is also same.

hughie gravatar imagehughie ( 2016-03-07 21:41:33 -0600 )edit

Yes. The same ROS repositories are used for all of the 14.04.x versions of Ubuntu, so I would expect the same trouble.

ahendrix gravatar imageahendrix ( 2016-03-08 00:22:31 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-03-07 21:11:41 -0600

ahendrix gravatar image

updated 2016-03-08 00:32:29 -0600

This is usually a temporary issue, and happens when you download packages at the same time that a repository sync is happening. It should go away if you try again a few minutes later.

Are you using an HTTP proxy?

Update

This error means that the checksum on the Packages file ( http://packages.ros.org/ros/ubuntu/di... ) doesn't match the checksum that is listed in the Release file ( http://packages.ros.org/ros/ubuntu/di... ). I guess you could download both files and try to manually verify the checksums.

When I compute the checksums on the Packages file, I get:

$ wget http://packages.ros.org/ros/ubuntu/dists/trusty/main/binary-amd64/Packages
$ sha1sum Packages 
058296435aba9ad217d436d338c9a19a37e0df74  Packages
$ md5sum Packages 
e8f069b226d4fa7155e90ef02f3235ec  Packages

And these match the checksums listed in the Release file (these checksums will be out of date in a few days, so be sure to check against the most recent copy of the Release file, and not the checksums listed here).

edit flag offensive delete link more

Comments

Thank you for your answer. I don't use HTTP proxy and other Ubuntu package index are fine. I also tried with China mirror(http://wiki.ros.org/ROS/Installation/UbuntuMirrors). but, It has same problem.

hughie gravatar imagehughie ( 2016-03-07 21:44:57 -0600 )edit

It's working now. now checksum on the packages file and checksum that is listed in the Release file are matched. maybe the checksums is fixed in the server. Thank you for helping me!

hughie gravatar imagehughie ( 2016-03-08 18:12:08 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-07 20:51:00 -0600

Seen: 1,402 times

Last updated: Mar 08 '16