Ask Your Question
0

WSL: Ubuntu on Windows 10, unable to see published topics

asked 2020-03-16 10:23:37 -0500

ghaggin gravatar image

updated 2020-03-16 10:34:26 -0500

I'm am trying to work with ROS2-eloquent on Ubuntu for Windows 10. I would like to create multiple nodes that can pass messages to one another while running independently in different terminals. I can recreate my problem using the talker/listener demo nodes.

I open a new Ubuntu terminal in Windows 10. Then I run tmux so that I can open multiple terminals in this instance of Ubuntu. In the first tmux pane, I run

source /opt/ros/eloquent/setup.bash
ros2 run demo_nodes_cpp talker

The node prints the expected output.

Now i open a new pane in tmux and run

source /opt/ros/eloquent/setup.bash
ros2 run demo_nodes_cpp listener

No output prints to the screen making me think that the listener is unable to subscribe to the topic that the talker is publishing. Now I kill the listener and run

ros2 topic list

which only prints

/parameter_events
/rosout

and nothing prints for

ros2 topic list

All of this works find when I run this on Ubuntu 18.04 running natively. I'm not familiar with how Ubuntu on Windows 10 operates under the hood and I would appreciate if anyone could help me solve this problem.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-03-16 13:06:45 -0500

ghaggin gravatar image

Fixed by switching to wsl2 on windows insider.

edit flag offensive delete link more

Comments

For the purposes of multi-machine setups, this will not work. It only allows for ROS2 to work internally withing WSL2.

cwillia109 gravatar image cwillia109  ( 2020-05-23 14:58:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-03-16 10:23:37 -0500

Seen: 315 times

Last updated: Mar 16 '20