Ask Your Question
0

CRAM MoveIt Tutorial problem

asked 2016-03-05 18:35:28 -0500

abestick gravatar image

I'm working through the first tutorial on using MoveIt with CRAM, and I'm able to load the tutorial module, query the state of the robot, etc. without problems.

However, when I try to move the robot with the line

(move-link-pose "r_wrist_roll_link" "right_arm" tuti:*pose-mid*)

the REPL shows

[(MOVEIT) ERROR] 1457223557.388: Empty actionlib response.

and the MoveIt terminal window says

[ERROR] [1457223552.356453336]: Exception thrown when deserializing message of length [5034] from [/tutorial-client]: Buffer Overrun

What might be the problem? I thought that maybe some piece of CRAM code was built against an old version of moveit_msgs, but I've tried catkin_make-ing in a clean workspace with no change.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-07 14:13:57 -0500

gaya gravatar image

I just tried out the tutorial and the call succeeded for me.

Which version of cram_moveit and cram_tutorials are you using?

The link to the repository in the tutorial was a bit outdated, so I updated it now (and also cleaned up the code in the repo a bit). If you're using cram_moveit version 0.2.1 (see package.xml), then cloning from the updated link in the tutorial might help.

edit flag offensive delete link more

Comments

I was indeed using 0.2.1, and updating the cram_tutorials package as you suggested fixed it! Thanks!

abestick gravatar image abestick  ( 2016-03-07 18:15:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-05 18:35:28 -0500

Seen: 93 times

Last updated: Mar 07 '16