Ask Your Question
0

Problem loading cram_language in SLIME

asked 2011-10-03 18:59:47 -0600

biyonder gravatar image

Hi. I have a problem. I set up cram_emacs_repl (because I'm a bit lazy :P). SLIME loads well but when I run the command (ros-load:load-system "cram_language" :cram_language) to use the package CPL, it says:

Component "cram_language" not found

I don't understand the problem. I have the ROS_PACKAGE_PATH configured correctly and ROS finds cram_language package with the command 'rospack find' but in SLIME doesn't.

Thanks!

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-10-05 18:56:47 -0600

biyonder gravatar image

Ok. However, I followed the steps at here and when I do rosmake in roslisp_repl gives:

[ rosmake ] Packages requested are: ['roslisp_repl'] [ rosmake ] Logging to directory [ rosmake ] /home/biyonder/.ros/rosmake/rosmake_output-20111006-075129 [ rosmake ] Expanded args ['roslisp_repl'] to: [] [ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['roslisp_repl'] [ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

It seems there doesn't find roslisp_repl as package or stack. The path ~/cram-ros is correctly set in $PATH.

Thanks.

edit flag offensive delete link more

Comments

Did you try 'source ~/cram-ros/setup.bash' and then a 'roscd roslisp_repl'? If that works, 'rosmake roslisp_repl' should also work.
Lorenz gravatar imageLorenz ( 2011-10-06 05:03:22 -0600 )edit
0

answered 2011-10-04 22:25:32 -0600

biyonder gravatar image

I saw in other post that I must do 'rosmake cram_language' but there exists other problem:

WARNING: Rosdep did not detect the following system dependencies as installed: coreutils, sbcl Consider using --rosdep-install option or rosdep install cram_language

If I tip 'rosdep install cram_language' there exists a problem with coreutils:

Failed to find rosdep coreutils for package cram_language on OS:ubuntu version:lucid rosdep install ERROR: failed to install coreutils

Can anybody help me? Thanks!

edit flag offensive delete link more
0

answered 2011-10-05 05:04:55 -0600

Lorenz gravatar image

If you have ros-electric-roslisp-support installed, sbcl should be pulled in automatically. Also, we just made a new release of roslisp_support and roslisp_common. With the update of your debian packages, you shouldn't require cram_emacs_repl anymore. Instead, you can then use the package roslisp_repl. Also, check out this question.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-03 18:59:47 -0600

Seen: 213 times

Last updated: Oct 05 '11