Ask Your Question
0

Setting up emacs with rosemacs

asked 2012-02-02 02:08:26 -0600

wkr101 gravatar image

updated 2014-01-28 17:11:15 -0600

ngrennan gravatar image

I followed the information for installing rosemacs but this has presented me with some problems. For starters, I didn't have a .emacs file so I created one from scratch (not sure if that's what is supposed to be done). I tried editing this file in both ways described but I keep getting errors.

Warning (initialization): An error occurred while loading /home/usr/.emacs':
File error: Cannot open load file, rosemacs
To ensure normal operation, you should investigate and remove the
cause of the error in your initialization file.  Start Emacs with
the--debug-init' option to view a complete error backtrace.

I did exactly that, opening emacs in debug mode through the command line:

$emacs --debug-init

This yields the following in the scratch area once emacs is open:

͂͂͂
Debugger entered--Lisp error: (file-error "Opening directory" "permission denied" "/home/usr/.emacs.d/auto-save-list/")
 directory-files("~/.emacs.d/auto-save-list/" nil "\`\.saves-" t)
 (and auto-save-list-file-prefix (file-directory-p (file-name-directory auto-save-list-file-prefix)) (directory-files (file-name-directory auto-save-list-file-prefix) nil (concat "\`" ...) t))
  delete-process(#<process *rostopic-tracker*&gt;)="" (progn="" (message="" "cancelling="" existing="" rostopic="" tracker")="" (delete-process="" old-proc))="" (if="" old-proc="" (progn="" (message="" "cancelling="" existing="" rostopic="" tracker")="" (delete-process="" old-proc)))="" (when="" old-proc="" (message="" "cancelling="" existing="" rostopic="" tracker")="" (delete-process="" old-proc))="" (let="" ((old-proc="" ...))="" (when="" old-proc="" (message="" "cancelling="" existing="" rostopic="" tracker")="" (delete-process="" old-proc)))="" (let="" ((name="" "<em="">rostopic-tracker")) (let (...) (when old-proc ... ...)) (when (> interval 0) (let ... ... ...)))
  rosemacs/track-topics(8)
  invoke-rosemacs()
  (progn (add-to-list (quote load-path) checked-result) (require (quote rosemacs)) (invoke-rosemacs))
  (progn (progn (add-to-list ... checked-result) (require ...) (invoke-rosemacs)))
  (if checked-result (progn (progn ... ... ...)))
  (when checked-result (progn (add-to-list ... checked-result) (require ...) (invoke-rosemacs)))
  (let* ((result ...) (checked-result ...)) (when checked-result (progn ... ... ...)))
  eval-buffer(#<buffer *load*&gt;="" nil="" "="" home="" usr="" .emacs"="" nil="" t)="" ;="" reading="" at="" buffer="" position="" 517="" load-with-code-conversion("="" home="" usr="" .emacs"="" "="" home="" usr="" .emacs"="" t="" t)="" load("~="" .emacs"="" t="" t)="" <="" code="">

If anyone has an idea as to what might be going on please let me know.

edit retag flag offensive close merge delete

Comments

Could you post the relevant part of your .emacs as well?
Ugo gravatar imageUgo ( 2012-02-02 03:25:48 -0600 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2012-02-02 05:45:15 -0600

Ugo gravatar image

Ho! Apparently you don't have the permission to browse this directory:

(file-error "Opening directory" "permission denied" "/home/usr/.emacs.d/auto-save-list/")

This can be solved by running:

sudo chmod -R a+rw /home/usr/.emacs.d

Hope this helps.

edit flag offensive delete link more

Comments

BINGO!! Thanks Ugo, that solved it! I had a feeling it would be something simple like that.
wkr101 gravatar imagewkr101 ( 2012-02-02 21:56:44 -0600 )edit
Happy to help :) You should probably select this as the correct answer then.
Ugo gravatar imageUgo ( 2012-02-02 22:02:48 -0600 )edit
I didn't see an option for this. Is it the "mark answer as favorite" (checkmark) option? If so, I just did that.
wkr101 gravatar imagewkr101 ( 2012-02-02 22:43:22 -0600 )edit
2

answered 2012-02-02 06:17:09 -0600

Mac gravatar image

Your .emacs file is a per-user configuration file; it should be in /home/whatever, not in /usr, which is for system libraries and shared data.

edit flag offensive delete link more

Comments

Sorry, I must have confused you with the naming convention. It's not in /usr it's in the home directory as you stated. It's just that the "whatever" is called "usr" in this case.
wkr101 gravatar imagewkr101 ( 2012-02-02 21:52:51 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-02 02:08:26 -0600

Seen: 978 times

Last updated: Feb 02 '12