Ask Your Question
1

rviz Bus error on Nvidia Jetson tx1 board

asked 2016-01-12 23:23:20 -0600

fujisys gravatar image

Hi,

I am trying to run rviz on Nvidia Jetson Tx1 board, but the following error appears:

Bus error

Could anyone help me?

edit retag flag offensive close merge delete

Comments

Hi, have you solved this problem? Could you teach me? I meet the same problem!

Sally gravatar imageSally ( 2016-08-29 07:30:57 -0600 )edit

Hi, have you solved this problem? Could you teach me? I meet the same problem!

Winston gravatar imageWinston ( 2016-10-16 06:12:01 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-02-13 19:59:23 -0600

sjobeek gravatar image

You need to run: unset GTK_IM_MODULE

From the ROS Arm instruction page: http://wiki.ros.org/indigo/Installati...

Using RVIZ It is not recommended to run rviz on most ARM-based CPUs. They're generally too slow, and the version of OpenGL that is provided by the software (mesa) libraries it not new enough to start rviz.

'IF' you have a powerful board with a GPU and vendor-supplied OpenGL libraries, it might be possible to run rviz. The IFC6410 and the NVidia Jetson TK1 are two such boards where rviz will run, although neither is fast enough for graphics-heavy tasks such as displaying pointclouds.

Note that rviz will segfault if you have the GTK_IM_MODULE environment variable set, so it's best to unset it in your ~/.bashrc:

unset GTK_IM_MODULE

edit flag offensive delete link more

Comments

Hi, i followed your advice but unsuccessed!

Winston gravatar imageWinston ( 2016-10-16 06:14:07 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-12 23:23:20 -0600

Seen: 1,233 times

Last updated: Jan 12 '16