Ask Your Question
0

Robot Monitor gives an error, how to set imu0_pose_covariance?

asked 2016-01-05 06:25:00 -0600

Orhan gravatar image

updated 2016-10-24 09:05:18 -0600

ngrennan gravatar image

Hi, Robot Monitor says:

imu0_pose_covariance: The covariance at position (35), which corresponds to YAW variance, was zero. This will be replaced with a small value to maintain filter stability, but should be corrected at the message origin node.

I've set this under ekf_localization tag in my controls.yaml file;

     ...
     ekf_localization:
       ...
       imu0_pose_covariance: [1e-5, 0.0, 0.0, 0.0, 0.0, 0.0,
                              0.0, 1e-5, 0.0, 0.0, 0.0, 0.0,
                              0.0, 0.0, 1e-5, 0.0, 0.0, 0.0,
                              0.0, 0.0, 0.0, 1e-5, 0.0, 0.0,
                              0.0, 0.0, 0.0, 0.0, 1e-5, 0.0,
                              0.0, 0.0, 0.0, 0.0, 0.0, 1e-5]
       ...

But still no effect. How can I set this? Or How can I correct this problem? Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-02-05 07:58:38 -0600

Tom Moore gravatar image

imu0_pose_covariance is not a setting for ekf_localization_node. The covariances for measurements, including IMU data, come from the sensor_msgs/Imu message itself. Check your IMU driver.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-05 06:17:57 -0600

Seen: 166 times

Last updated: Feb 05 '16