Ask Your Question
0

compiling MAVROS generates error

asked 2015-12-30 10:34:07 -0500

John Setzer gravatar image

updated 2015-12-30 16:16:46 -0500

gvdhoorn gravatar image

We need to build MAVROS from source and are getting the following error:

 [ 88%] Building CXX object mavros/mavros/CMakeFiles/mavros_plugins.dir/src/plugins/altitude.cpp.o
/home/john/catkin_ws/src/mavros/mavros/src/plugins/altitude.cpp: In member function ‘void mavplugin::AltitudePlugin::handle_altitude(const mavlink_message_t*, uint8_t, uint8_t)’:
/home/john/catkin_ws/src/mavros/mavros/src/plugins/altitude.cpp:61:71: error: ‘mavlink_altitude_t’ has no member named ‘time_usec’
         ros_msg->header = uas->synchronized_header(frame_id, altitude.time_usec);
                                                                       ^
make[2]: *** [mavros/mavros/CMakeFiles/mavros_plugins.dir/src/plugins/altitude.cpp.o] Error 1

The source was obtained from https://github.com/mavlink/mavros and receive the same error when trying https://github.com/vooon/mavros as well. I tried straight GIT cloning as well as WSTOOL to install source and used catkin_make. This was generated on an Ubuntu Trusty version with ROS Indigo.

Any advice would be greatly appreciated,

John Setzer

edit retag flag offensive close merge delete

Comments

[..] as well as WSTOOL to install source [..]

What did you expect wstool would do differently?

gvdhoorn gravatar image gvdhoorn  ( 2015-12-30 16:17:14 -0500 )edit

Did you install mavlink?

tonybaltovski gravatar image tonybaltovski  ( 2015-12-30 18:17:18 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2016-01-03 21:22:14 -0500

vooon gravatar image
  1. Update mavlink package. Please follow instructions from readme or more explained guide
  2. vooon/mavros and mavlink/mavros it is the same repo.
edit flag offensive delete link more
0

answered 2016-02-01 08:57:35 -0500

YingHua gravatar image

Hi , do you solve it now?

I get the same error and tried all the ways I google.

Here is my error log image description

I mark it like this and build success.

/home/john/catkin_ws/src/mavros/mavros/src/plugins/altitude.cpp

//ros_msg->header = uas->synchronized_header(frame_id, altitude.time_usec);

It build successful and ok to run.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-30 10:34:07 -0500

Seen: 573 times

Last updated: Feb 01 '16