rgbslamv2 compile error missing cuda.h

asked 2015-10-23 05:08:31 -0500

rossi gravatar image

updated 2015-10-23 08:05:12 -0500

Hello ROS community, I try to compile the rgbdslamv2 (folowing instruction http://felixendres.github.io/rgbdslam... ). I get the error, that cuda.h is missing. I deactivate the cuda option in the CMakelists.txt, but activate the SiftGpu with GLSL. Also it cant find -lsiftgpu (see picture).

image description

image description

If i deactivate Siftgpu at all in the CMakelists.txt and activate pcl_icp, the compilation complete without errors, but crash when i start any launch file with the error:

REQUIRED process [rgbdslam-2] has died! process has died [pid 4120, exit code-11, cmd /home/pem/rgbdslam_catkin_ws/devel/lib/rgbdslam/rgbdslam __name:=rgbdslam __log:=/home/pem/.ros/log/86f0937e-3be5-11e5-8018-c86000307f44/rgbdslam-23.log]. log file: /home/slam/.ros/log/86f0937e-3be5-11e5-8018-c86000307f44/rgbdslam-23*.log Initiating shutdown!

I add c++11 to the CMakeLists.txt in rgbdslam( is this right?): SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11") and try to change the line: find_package(PCL 1.7 REQUIRED COMPONENTS common io) to find_package(PCL 1.8 REQUIRED COMPONENTS common io) but i get the error, it cant find pcl 1.8.

(i see it here: https://github.com/felixendres/rgbdsl... )

what is wrong?

Allready solved Problems:

Error1: Catkin_make Error "No rule to make target /usr/lib/libcxsparse.so.2.2.3', needed by/home/zarneel/rgbdslam_catkin_ws/devel /lib/rgbdslam/rgbdslam'. Stop"

solved it: In Workspace src/rgbdslam_v2/CmakeLists.txt under „set libs“ exchange the code „#SET(LIBS_LINK GL GLU cholmod /usr/lib/libcxsparse.so.2.2.3 ${G2O_LIBRARIES} ${QT_LIBRARIES} ${QT_QTOPENGL_LIBRARY} ${GLUT_LIBRARY} ${OPENGL_LIBRARY} ${OpenCV_LIBS})“ to SET(LIBS_LINK GL GLU cholmod /usr/lib/x86_64-linux-gnu/libcxsparse.so.3.1.2 ${G2O_LIBRARIES} ${QT_LIBRARIES} ${QT_QTOPENGL_LIBRARY} ${GLUT_LIBRARY} ${OPENGL_LIBRARY} ${OpenCV_LIBS})

Error2: opencv2/nonfree/features2d.hpp no such file or directory

Update opencv:

sudo add-apt-repository --yes ppa:xqms/opencv-nonfree

sudo apt-get update

sudo apt-get install libopencv-nonfree-dev

My Systems runs on Ubuntu 14.04 ROS Indigo

edit retag flag offensive close merge delete