Ask Your Question
0

enable gpu in Autoware??: failed to build with AUTOWARE_COMPILE_WITH_CUDA=1 /. colcon release

asked 2019-06-21 03:28:34 -0500

AM97 gravatar image

updated 2019-06-30 18:46:15 -0500

Geoff gravatar image

I would like to how can i enable GPU in autoware.

Operating system and version: Ubuntu 18.04 gcc (Ubuntu 7.4.0-1ubuntu1~18.04.1) 7.4.0 cmake version 3.10.2

Autoware installation type Built from source (https://gitlab.com/CPFL/Autoware)

Autoware version or commit hash output of git rev-parse HEAD (42aba1468490e2ed218f9295ab3e7490db864e54)

ROS distribution: melodic ROS installation type: sudo apt-get install ros-melodic-desktop-full

GPU MODEL: GeForce GTX 1060M

Drivers Driver Version: 418.56

CUDA Version: 10.1

CUDNN Version: 7.5

 NVIDIA-SMI 418.56       Driver Version: 418.56       CUDA Version: 10.1     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1060    Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   67C    P3    19W /  N/A |    555MiB /  6078MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1688      G   /usr/lib/xorg/Xorg                           301MiB |
|    0      2185      G   /usr/bin/gnome-shell                         142MiB |
|    0      2777      G   ...uest-channel-token=15888348073250092753   109MiB |

If I am using colcon build the build was successful with stderr outputs for 12 packages (https://answers.ros.org/question/3265...)

but if I am Compile with AUTOWARE_COMPILE_WITH_CUDA=1 ./colcon_release this command I am getting this following error

sai@sai-Blade:~$ cd Autoware/ros
sai@sai-Blade:~/Autoware/ros$ AUTOWARE_COMPILE_WITH_CUDA=1 ./colcon_release
Starting >>> autoware_build_flags
Starting >>> autoware_msgs
Starting >>> autoware_config_msgs
Starting >>> tablet_socket_msgs
Starting >>> autoware_system_msgs
Starting >>> autoware_can_msgs
Starting >>> gnss
Starting >>> sick_ldmrs_description
Finished <<< sick_ldmrs_description [5.85s]                                  
Starting >>> sick_ldmrs_msgs
Finished <<< autoware_build_flags [5.99s]                                    
Starting >>> vector_map_msgs                                        
Finished <<< gnss [9.86s]                                               
Starting >>> custom_msgs
Finished <<< autoware_can_msgs [20.4s]                                    
Starting >>> gazebo_camera_description
Finished <<< tablet_socket_msgs [21.4s]                                   
Starting >>> gazebo_imu_description
Finished <<< autoware_system_msgs [22.3s]                                 
Starting >>> autoware_health_checker
Finished <<< sick_ldmrs_msgs [21.2s]                                       
Starting >>> sick_ldmrs_driver
Finished <<< gazebo_camera_description [7.91s]                             
Starting >>> ndt_cpu
Finished <<< gazebo_imu_description [7.47s]                             
Starting >>> ndt_tku
Finished <<< autoware_config_msgs [28.9s]
Starting >>> pcl_omp_registration
Finished <<< autoware_msgs [35.7s]                                            
Starting >>> amathutils_lib                                                  
Finished <<< ndt_tku [8.18s]                                                 
Starting >>> astar_search
Finished <<< custom_msgs [31.3s]                                             
Starting >>> runtime_manager
Finished <<< runtime_manager [7.21s]                                         
Starting >>> tablet_socket
--- stderr: pcl_omp_registration                                             
** WARNING ** io features related to ensenso will be disabled
** WARNING ** io features related to davidSDK will be disabled
** WARNING ** io features related to dssdk will be disabled
** WARNING ** io features related to pcap will be disabled
** WARNING ** io features related to png will be disabled
** WARNING ** io features related to libusb-1.0 will be disabled
** WARNING ** visualization features related to ensenso will be disabled
** WARNING ** visualization features related to davidSDK will be disabled
** WARNING ** visualization features related to dssdk will be disabled
** WARNING ** visualization features related to rssdk will be disabled
---
Finished <<< pcl_omp_registration [44.5s]
Starting >>> fastvirtualscan
Finished <<< tablet_socket [33.0s]            
Starting >>> kitti_box_publisher
--- stderr: ndt_cpu                           
** WARNING ** io features related to ensenso will be disabled
** WARNING ** io features related to davidSDK will be disabled
** WARNING ** io features related to dssdk will be disabled
** WARNING ** io features related to pcap will be ...
(more)
edit retag flag offensive close merge delete

Comments

Hi guys i installed autoware without CUDA yet still have the same error above. Any ideas ?

sneibus gravatar image sneibus  ( 2020-04-12 16:05:46 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2019-06-30 18:50:12 -0500

Geoff gravatar image

Because you are using ROS Melodic and Ubuntu 18.04, you must use the bleeding edge release of Autoware (1.12.0-alpha.2).

You are also required to use CUDA 10.0. Version 10.1 will not work. See the requirements for dependencies.

edit flag offensive delete link more
0

answered 2020-03-12 17:22:58 -0500

omkard gravatar image

updated 2020-04-10 16:47:33 -0500

@AM97 @Geoff I had the same issue with installing Autoware using the source code. Finally I got it worked by following these steps:

Installation of CUDA 10.0 and setting up NVIDIA graphics card

  1. Download gcc 6 first from here
  2. Download CUDA 10.0 from here. Also while installing cuda use sudo apt-get install cuda-10.0. Used this as a complete installation guide.
  3. Download nvidia 430 driver from here.
  4. Run the benchmark using Unigine Heaven 4.0
  5. Verify the installation from here

Installation of Ros Melodic, installing system dependencies, updating eigen values and installing Autoware

  1. Install Ros Melodic from here

  2. Check for ros installation using this command rosversion -d

  3. Install all the system dependencies from here and follow along to download and install Autoware.

Thanks!

edit flag offensive delete link more

Comments

Installation of gcc 6 should most definitely not be required. The entire stack builds perfectly fine with the version of gcc provided with Ubuntu. If it does have issues, then it's a bug with the stack, not with the version of gcc and should be corrected in Autoware.

In addition, the link to instructions that you provide uses ppa:graphics-drivers which is unnecessary and potentially dangerous. Installing cuda-10-0 from the official Nvidia site is recommended and an appropriate driver will be installed automatically, if required, from the NVIDIA repo.

Josh Whitley gravatar image Josh Whitley  ( 2020-03-12 22:00:06 -0500 )edit

Hi @Josh Whitley,

Sorry for replying late. I had gcc version of 7 with the ubuntu I had and I started to build the Autoware. But, the build stopped in the middle saying that gcc version of 6 or less is needed. That's why I had to redo the whole thing again with gcc6 (right from reinstalling OS to building the Autoware). And it worked.

And sorry for misguiding with ppa:graphics-drivers. I will remove that link.

omkard gravatar image omkard  ( 2020-04-10 16:47:09 -0500 )edit
-1

answered 2020-04-13 07:31:44 -0500

sneibus gravatar image

Hi guys i installed autoware yet still have the same error above. Any ideas ? $ roslaunch runtime_manager runtime_manager.launch ... logging to /home/claytex/.ros/log/1f65592c-7d82-11ea-9477-708bcd595ab7/roslaunch-CLAYTEX33-13460.log Checking log directory for disk usage. This may take a while. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://CLAYTEX33:63439/

SUMMARY

PARAMETERS * /rosdistro: melodic * /rosversion: 1.14.5

NODES / run (runtime_manager/run)

auto-starting new master process[master]: started with pid [13520] ROS_MASTER_URI=http://localhost:11311

setting /run_id to 1f65592c-7d82-11ea-9477-708bcd595ab7 process[rosout-1]: started with pid [13531] started core service [/rosout] process[run-2]: started with pid [13534] sudo: no tty present and no askpass program specified /home/claytex/autoware.ai/install/runtime_manager/share/runtime_manager/scripts/run: line 53: --geometry=50x10+500+0: command not found [run-2] process has died [pid 13534, exit code 127, cmd /home/claytex/autoware.ai/install/runtime_manager/share/runtime_manager/scripts/run __name:=run __log:=/home/claytex/.ros/log/1f65592c-7d82-11ea-9477-708bcd595ab7/run-2.log]. log file: /home/claytex/.ros/log/1f65592c-7d82-11ea-9477-708bcd595ab7/run-2*.log

edit flag offensive delete link more

Comments

1

Please do not post answers unless you are answering a question.

You appear to have a new issue, so post it as a new question. Then refer to this one if that is relevant.

gvdhoorn gravatar image gvdhoorn  ( 2020-04-13 07:44:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-06-21 03:28:34 -0500

Seen: 727 times

Last updated: Apr 13