Problem using pointcloud data in NVIDIA Jetson Xavier NX

asked 2022-02-24 02:52:49 -0600

ckashis gravatar image

I have been trying to use pointcloud data for autonomous navigation of my mobile robot. I am using an Intel Realsense D435i sensor. Everything works fine when I use my Laptop for navigation. But I am facing problems when I run the same package in NVIDIA Jetson Xavier NX. The robot is not able to navigate when I use Jetson Xavier NX. I am using pointcloud_to_laserscan package for navigation. I tried depthimage_to_laserscan package also in the similar way. But nothing worked. The realsense-viewer is opening in Jetson but the processing is very slow. I have connected the camera separately to Jetson and used Realsense Wrapper package for getting the camera topics. I want to use /camera/depth/color/points topic for my purpose. Topics are being published but data is not coming. So I am not able to visualize the pointclouds in RViz. It is showing a warning as follows.

[ WARN] [1645684556.525396941]: No stream match for pointcloud chosen texture Process - Color

The Jetson Xavier NX which I am using has the following specifications.

  • 8 GB 128-bit LPDDR4x memory
  • 6-core NVIDIA Carmel ARM v8.2 64-bit CPU
  • 384-core NVIDIA Volta GPU with 48 Tensor Cores
  • ROS Noetic

I followed the same procedure using my Laptop and everything worked really well. Even I am able to do navigation also. I have installed Ubuntu on SSD of my Laptop. The specifications of my Laptop are given below.

  • Lenovo Legion Intel Core i7 with 16GB RAM
  • 1 TB HDD and 128 GB SSD
  • NVIDIA GP107M GPU
  • ROS Noetic on Ubuntu 20.04

I saw this question in ROS answers which tells that we need to use GPU for using pointclouds. Please help me if the GPU has to be enabled in my Jetson Xavier NX or if it is an error with librealsense.

edit retag flag offensive close merge delete

Comments

What installation procedure did you use on the Jetson? https://github.com/IntelRealSense/lib... ?

peci1 gravatar image peci1  ( 2022-02-26 09:15:57 -0600 )edit

I followed the same procedure described in the link you have provided. But I still face the same issue. I opened realsense-viewer to find whether it is an error with librealsense installation or not. It opened and I couldn't find any error. I even tried to run the package from SSD (link).

ckashis gravatar image ckashis  ( 2022-03-02 23:10:46 -0600 )edit

And the non-colored pointcloud is coming? What exact launch file are you using?

peci1 gravatar image peci1  ( 2022-03-03 02:41:52 -0600 )edit

Non-colored pointclouds are not coming. I am using the rs_camera.launch file in realsense2_camera package present here.

ckashis gravatar image ckashis  ( 2022-03-03 04:37:19 -0600 )edit

Give a try to rs_rgbd.launch

peci1 gravatar image peci1  ( 2022-03-03 05:02:58 -0600 )edit

Has anyone figured this problem out? I am facing the same issue on similar configuration and there is no point cloud being published on topic even though it is availale.

andrew30 gravatar image andrew30  ( 2022-10-10 09:40:13 -0600 )edit