ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Turtlebot3 description not found.

asked 2021-11-08 06:16:30 -0500

Roshan gravatar image

updated 2021-11-08 06:18:25 -0500

Had issues with my ROS since some packages were deleted (https://answers.ros.org/question/3903...), so tried re-installing. Now I'm getting this error:

Resource not found: turtlebot3_description
ROS path [0]=/opt/ros/noetic/share/ros
ROS path [1]=/home/roshan/Documents/ROS/turtlebot_test/src
ROS path [2]=/opt/ros/noetic/share
The traceback for the exception was written to the log file

And looking through the files in the /opt/ros/noetic/share, there is no turtlebot3_description. Have done

source devel/setup.bash

, still getting the error. Have also tried reinstalling the turtlebot3_simulations package in my workspace and catkin_make, still getting the issue

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-11-08 06:36:04 -0500

Roshan gravatar image

Had to manually install this package, which is weird since it used to come automatically when installing ROS Noetic or turtlebot3 sim

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2021-11-08 06:16:30 -0500

Seen: 505 times

Last updated: Nov 08 '21