Ask Your Question
0

installation fails trying to fix dependencies

asked 2015-10-01 05:11:54 -0500

juwinkler gravatar image

updated 2015-10-04 12:59:23 -0500

I do not know what to do. everytime I try to use "sudo apt-get install ros-jade-desktop-full", terminal tells me there were unfulfilled dependencies. However, I did not set any of these and I do not know how to remove them. Nevertheless, I really need to install ROS... Do you know what I can change in order to make it work? Thank you very much!

PS: the problem appears in this step:

sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libxatracker-dev-lts-utopic libopenvg1-mesa-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libgbm-dev-lts-utopic libegl1-mesa-dev-lts-utopic

OR

sudo apt-get install libgl1-mesa-dev-lts-utopic

(as one of them did not work, I tried the other one, too. My ubuntu version is 15.04).

The error messages:

E: Paket xserver-xorg-dev-lts-utopic kann nicht gefunden werden.
E: Paket mesa-common-dev-lts-utopic kann nicht gefunden werden.
E: Paket libxatracker-dev-lts-utopic kann nicht gefunden werden.
E: Paket libopenvg1-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgles2-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgles1-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgl1-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgbm-dev-lts-utopic kann nicht gefunden werden.
E: Paket libegl1-mesa-dev-lts-utopic kann nicht gefunden werden.

("kan nicht gefunden werden" means "cannot be found"). I do not know why this happens. I my settings for "Software and Updates" for "download from" is "main server" (changing it to German server does not change anything). Of course, I have also done each of the first steps described in the download tutorial. I am sure that I did not type in anything wrong.

edit retag flag offensive close merge delete

Comments

1

Please copy/paste the exact errors into your question (use the edit button/link for that). Without information we cannot help you. Please format error text using the Preformatted text button on the toolbar (it's the one with 101010 on it).

gvdhoorn gravatar imagegvdhoorn ( 2015-10-01 06:01:47 -0500 )edit

Okay, thank you, I edited the post :) Do you have an idea how to solve the problem?

juwinkler gravatar imagejuwinkler ( 2015-10-04 04:51:16 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
0

answered 2015-10-14 22:58:44 -0500

tfoote gravatar image

You appear to be following these insructions: http://wiki.ros.org/jade/Installation...

The section you're following is for 14.04.2 only. You can skip that on 15.04

edit flag offensive delete link more

Comments

yes, I follow the instructions. if I do not follow them and start to install ros, it does not work. also, i cannot install it by klicking on installing when I use the non-terminal method. an error message says that there are dependency problems. thus, i conclude, i do have to fix them... :/

juwinkler gravatar imagejuwinkler ( 2015-10-15 12:18:25 -0500 )edit

You have provided the console output from the part you don't need to do, but have not provided details on the later message. Please provide enough information for us to reproduce the problem and see exactly what you're typing and getting as an output for us to be able to help you better.

tfoote gravatar imagetfoote ( 2015-10-15 12:43:52 -0500 )edit
1

answered 2015-10-04 13:06:17 -0500

wsAndy gravatar image

Why not install ros-indigo , have a try. if you really don't how to solve this problem . as you said you cannot remove them too, why not reinstall your system? That sounds like a crazy thing but will save a lot time for you.

edit flag offensive delete link more
0

answered 2015-10-04 13:51:46 -0500

juwinkler gravatar image

I just installed the system one week ago, so I do not want to do that again.. I first of all wanted to install indigo. However, there were always fails, so that I had to install jade...

Also, my friends installed ros jade on their ubuntu 15.04 last week. Thus, it is impossible that something is missing.

edit flag offensive delete link more

Comments

Come on... It will be frequent for a newer to install system and ROS..

wsAndy gravatar imagewsAndy ( 2015-10-04 21:21:56 -0500 )edit

so you think I really have to do everything again? Is there really no other chance to install ros than installing the whole system? I mean, why should I install the system new? What is wrong with it?

juwinkler gravatar imagejuwinkler ( 2015-10-05 01:29:59 -0500 )edit

No, you can also solve this problem without reinstalling the system. I think it's due to your main server, you said you have change the software and update , maybe you should change it again.. That's all I can do for you.

wsAndy gravatar imagewsAndy ( 2015-10-05 04:30:55 -0500 )edit
0

answered 2015-10-07 02:35:11 -0500

nightblue gravatar image

My advice is to you is use Indigo version instead of Jade. Since it is well proven version. Indigo works well with Ubuntu 14.04.2.

edit flag offensive delete link more

Comments

when I tried to install indigo, it never worked. the error message said that the packages could not be found in the source... that was the only reason why i tried installing jade... there, it worked

juwinkler gravatar imagejuwinkler ( 2015-10-15 12:20:13 -0500 )edit

What is your system? PC? Raspberry pi? or another single board computer with ARM? Normally there is no problem in installing ROS Indigo on standart PC (with Ubuntu 14.04.2). Try changing your PC platform! Try another PC or laptop! Or if you use windows you can first install vmware ubuntu then ROS.

nightblue gravatar imagenightblue ( 2015-11-02 03:01:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-01 05:11:54 -0500

Seen: 864 times

Last updated: Oct 14 '15